enable "highlight all" after the 4th keystroke -- fayt find as you type ahead find

RESOLVED WONTFIX

Status

()

Toolkit
Find Toolbar
--
enhancement
RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: M), Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

I use "highlight all" for something like 90% of my fayt searches.  

Can you make an about:config option where "hightlight all" becomes enabled after the 3rd or 4th keystroke?  

Really, there is no harm to have the highlights appear as such, because the first instance will be found, and there is great benefit to the user (no need to select 'hightlight all' and the visual highlight might be helpful).

Why the 3rd or 4th keystoke?  If enabled on the first and second keystroke, it will likely greatly slow down FF.  For example, there could be thousands of e's on a page and highlighting all on the first keystroke would be disastrous.

Secondly, I use the search marker extension and find it indispensable.  Please consider incorporating it into Firefox.  I imagine it will work trouble free if the above is implemented.  

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
Don't know why this was filled in the SeaMonkey component => Moving to Firefox
Component: Find In Page → General
Product: SeaMonkey → Firefox
QA Contact: keyboard.fayt → general
Version: unspecified → 2.0 Branch

Updated

7 years ago
Component: General → Find Toolbar
Product: Firefox → Toolkit
QA Contact: general → fast.find
Version: 2.0 Branch → Trunk

Updated

5 years ago
OS: Windows 2000 → All
We won't be implementing this specific feature request, but we are considering to turn 'Highlight All' on by default for all searches in bug 1193736.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.