Closed Bug 376226 Opened 14 years ago Closed 9 years ago

some sites cannot be reached when ipv6 enabled

Categories

(Core :: Networking, defect)

1.8 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: hramrach, Unassigned)

References

()

Details

(Keywords: qawanted)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

I cannot reach some sites when ipv6 is enabled in about:config.
On the other hand, I cannot reach an ipv6 site when disabled.

Reproducible: Always

Steps to Reproduce:
1. disable network.dns.disableIPv6 in about:config
2. go to freenetproject.org

Actual Results:  
Site does not load, after a long time Firefox stops loading it, and nothing is displayed.

Expected Results:  
The page loads normally.

The page works very fast when network.dns.disableIPv6 is enabled, and it works in Safari (whatever it does).

Also the ipv6 test site www.kame.net works correctly in Safari or when network.dns.disableIPv6 is disabled in Firefox.
Since I cannot find the OS X version in the collected data I should probably add this is on 10.4
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Version: unspecified → 1.8 Branch
Keywords: qawanted
Work-around from bug 377282 comment 9 (note that I can't repro since I can't seem to get IPv6 to work at all):

Please note that Bug 376226 can be easily solved: if you perform the DNS
resolution elsewhere (e.g. Safari, host from the command line) then the IPv6
connection works.

The issue appears to be with sites which have both an IPv4 _and_ IPv6 address
defined.  The sites in my example are IPv6 only and therefore work fine.

So the bug in 376226 appears to be rather more interesting as it occurs if and
only if the system resolver cache does not have a cached answer for the given
website _and_ the website has both and IPv6 and IPv4 address.
Blocks: 377383
Don't run on OS X currently so can't comment on this.

May be resolved by raising the OS X minimum version requirement, IIRC the dns lookups work better on 10.5 and even better on 10.6.
The same problem exists on Windows XP. For example, Firefox could not reach getfirefox.com until I disabled ip6.

As more sites use ip6 the number of unexplained blank pages has been increasing, so I'd suggest you increase the priority. Strangely, computer tech sites seem overrepresented (as also xkcd.com), so this could lead to some image problems soon.

Hard to keep track of which versions this has affected given the recent version inflation, but it's still there in 9.0.1.
This is wfm.
Older OS X versions had a few known issues with IPv6 but that should be now fixed.

James: You have a broken network setup.IPv6 should be preferred if your system have IPv6 connection. That you can't connect shows only that your ipv6 routing is broken.

This however got fixed with a IPv4 Fallback (happy eyeballs)
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Can confirm that a repair reinstall of Windows XP Pro fixed it. (Just resetting or removing and reinstalling all networking protocols and services was not enough.)
You need to log in before you can comment on or make changes to this bug.