Show signature in collapsible pane for editing/switching

RESOLVED WONTFIX

Status

P3
enhancement
RESOLVED WONTFIX
19 years ago
10 years ago

People

(Reporter: mpt, Assigned: bugzilla)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: See better solution proposed in bug 73567.)

(Reporter)

Description

19 years ago
The signature for a message should be shown in its own collapsible `signature 
frame' at the bottom of the window. This would allow direct editing of the 
signature, while retaining the identity of the signature so that bug 36480 
(`Change sig if identity is changed') can be fixed.

So the bottom of the composition window would look roughly like this:

||                                                                  |:||
||                                                                  |V||
|+------------------------------------------------------------------+-+|
|V-- Signature: [Mozilla sig   :^]   ( Save ... ) ( Clear ) ( Delete ) |
|+------------------------------------------------------------------+-+|
||Matthew `mpt' Thomas, Mozilla user interface QA                   |A||
||<http://critique.net.nz/project/mozilla/>                         |:||
||                                                                  |:||
||                                                                  |V||
|+------------------------------------------------------------------+-+|
|\+/ |V| ,' H"                          Mozilla ^   Open Windows ^  |//|
+-------------------------------------------------------------------'--+

Specs:

V: collapse button for signature frame. Just the same as the collapse buttons for 
toolbars etc. This frame should not be able to be dragged anywhere else in the 
window, because that could give the impression that the sig might appear 
somewhere other than at the bottom of the message, which would not be true. So 
the signature frame should not have a grippy, but should still be collapsible. 
When the signature frame is collapsed, the `Save ...' button is hidden as it does 
not apply, but the other buttons and the signature popup menu remain visible at 
the bottom of the window.

`-- ' in chrome: a reminder that the signature will be delimited with "-- ". 
Should be hidden (and not sent as part of the message) if the signature frame 
contans nothing (or nothing except whitespace), and restored as soon as
non-whitespace content is entered in the signature frame again. Should also be 
hidden (and not sent as part of the message) if the first three characters of the 
current contents of the signature frame happen to be "-- ".

`Signature:' popup menu: allows selection of a signature by filename from the 
user profile's signature directory. Selecting a signature from the menu replaces 
the current contents of the signature frame with the selected signature (no 
warning is necessary, even if the contents of the signature frame has been 
edited, as the loss of data is minor). The first item in this menu is `(custom)', 
followed by a menu separator, and then the list of available signatures. The 
`(custom)' item is disabled unless either {the contents of the signature frame 
has been edited since a signature was last selected from the `Signature:' menu 
(or since the composition window was opened)}, or {there are no signatures in the 
signature directory (in which case there are no other items in the menu)}. If 
either of those circumstances apply, the `(custom)' item is both enabled and 
selected.

( Save ... ): prompts for a name for the customized signature, and saves it in 
the user profile's signature directory. This button is only enabled if the 
contents of the signature frame has been edited since a signature was last 
selected from the `Signature:' menu (or since the composition window was opened).

( Clear ): clears the contents of the signature frame. This button is only 
enabled when the signature frame contains any content (including whitespace).

( Delete ): Opens a dialog -- `[large system font] Are you sure you want to 
delete this signature? [small system font] If you delete it, you will not be able 
to use this signature again unless you recreate it. ( Cancel ) (( Delete ))' If 
`Delete' is selected, the signature file is deleted from the signature directory, 
the contents of the signature frame remains unchanged, and the selected item in 
the signature popup menu is changed to `(custom)' (since the contents of the 
signature frame is now no longer directly derived from an existing signature).

The signature frame itself: Should be exactly four lines long, and not resizable 
(to encourage, without forcing, sigs of four lines or less). If `(custom)' is the 
currently selected item in the signature menu (for any of the reasons described 
above), the contents of the signature frame should be shown in the same color as 
is used when editing the rest of the message (e.g. black). Otherwise, the 
contents should be shown in the color set in preferences for signatures (once 
this color exists -- you might need a separate RFE for that).
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M20
(Reporter)

Comment 1

19 years ago
Clarifications:
* You need a `Signature Bar' checkbox item at the bottom of the `View' > `Show'
  submenu. This would operate slightly differently to the other `View' > `Show'
  items, in that it would expand or collapse the bar, rather than opening or
  closing it.
* The signature bar would be collapsed by default, but its state would be
  persistent between windows -- if I expanded the signature bar in one window,
  and then started a new message, the new message window would have the bar
  expanded.
* When in collapsed mode, the `Save ...', `Clear', and `Delete' buttons should
  not be present -- only the `Signature:' popup menu, and the twisty next to it.
  This would help to avoid UI clutter.
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future
(Reporter)

Comment 2

17 years ago
*** Bug 73567 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
Suggest to mark this bug invalid as it wastes screenspace, and bug 73567 has a
much better and cleaner solution. (see bug 73567 comment #8 and bug 73567
comment #14)

PS. Please also note the very few number of CC's and complete absence of
comments (other than the reporters) on this bug, even though it is much older
than bug 73567.

Comment 4

16 years ago
Correction: not invalid, but WONTFIX !?

Comment 5

16 years ago
comment #3 : The cause is in the subject of this bug. I think most people search
by "multi* sig*" and so they won't find this one. ;-)

Comment 6

16 years ago
This bug would make top-post + top-sig (bug 62429 comment #283) either
impossible or awkward (UI is at bottom, while sig would be placed above quoted
text).

Given the better solution proposed in bug 73567, I'm marking this bug WONTFIX.

Should anyone have an objection to this decision, please state *precisely* why.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Whiteboard: See better solution proposed in bug 73567.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.