Closed Bug 376544 Opened 13 years ago Closed 13 years ago

checkbox for sending invitations by email with ICS provider calendar

Categories

(Calendar :: Provider: ICS/WebDAV, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mdelorme, Assigned: cmtalbert)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.2pre) Gecko/20061023 SUSE/2.0.0.1-0.1 Firefox/2.0.0.2pre
Build Identifier: ftp://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/2007-04-04-03-mozilla1.8/linux-xpi/lightning.xpi

When selecting a ics calendar from the dropdown list on the new event dialog, the checkbox is always disabled.

Reproducible: Always

Steps to Reproduce:
1.create new event
2.select ics calendar
3.
Actual Results:  
the checkbox to send invitation by email is disabled

Expected Results:  
the checkbox to send invitation by email shoould be enabled

to correct this : 
add in /components/calICSCalendar.js
just after 
removeObserver: function (aObserver) {
        this.mObserver.removeObserver(aObserver);
    },
this 
---------------------------- at line 400
    get sendItipInvitations() { return true; },
-----------------------------
Flags: blocking-calendar0.5+
Version: unspecified → Trunk
Maxime, in the future please refrain from setting the blocking flag to "+". It should be set to "?" and the release driver will set it to "+".  However, I agree that this should block since it is an omission from bug 374757.  I've attached the patch you described in your comment.

Thanks for the bug.
Assignee: nobody → ctalbert.moz
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #260642 - Flags: first-review?(michael.buettner)
Comment on attachment 260642 [details] [diff] [review]
Patch described by Maxime

r=mickey
Attachment #260642 - Flags: first-review?(michael.buettner) → first-review+
Fix checked in on trunk and MOZILLA_1_8_BRANCH
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
VERIFIED with Tb 2.0.0.4pre & Lightning 0.5pre (2007052205) on Windows XP.
Status: RESOLVED → VERIFIED
Flags: blocking-calendar0.5+
You need to log in before you can comment on or make changes to this bug.