floaters should stack horizontally in compat mode

VERIFIED FIXED in M17

Status

()

Core
Layout
P1
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Alan S. Jones, Assigned: buster)

Tracking

({compat})

Trunk
x86
Windows 95
compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] [6/15], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Mozilla 2000042808 Win95

http://www.infoworld.com/articles/op/xml/00/04/24/000424opfoster.xml

The middle artile column is set below the left column.  Leaving a big blank 
space at the top of the page.

I know I have seen this bug before on another site, and thought it was fixed.  
Maybe it is a dupe of an open bug however I and a few others could not find it.
(Reporter)

Comment 1

18 years ago
Minor bug update to help reproduce and track the problem.
Some people were not able to reprodue this as their window was way to wide.  If 
the Window it to wide then the page looks fine.  Just make the browser window 
more narrow and it will reflow broken.  Just as you can fix the layout by making 
the page wider :)
Reassigning to Karnaze - Triaging Troy's bug list.
Assignee: troy → karnaze

Comment 3

18 years ago
Created attachment 8727 [details]
Two tables with ALIGN=LEFT and a fixed width, just like the original page.

Comment 4

18 years ago
Buster, Nav and IE put both tables (the attachment) on a single line for all 
viewport widths, but we don't. 
Assignee: karnaze → buster
(Assignee)

Comment 5

18 years ago
A better URL is:
 
http://www.infoworld.com/cgi-bin/deleteframe.pl?story=/articles/op/xml/00/04/24/
000424opfoster.xml
Status: NEW → ASSIGNED
(Assignee)

Comment 6

18 years ago
We're doing the "right" thing here, as per spec.  I've resisted putting in a 
quirks mode fix for this so far, but if it's very widespread, we may have to.

Other sites (zdnet, for example) were willing to fix their HTML.  In this case, 
the tables need to be put into a <DIV> that is as wide as the sum of the table 
widths that they want horizontally stacked on a single line.

Erik, would you care to speak with the folks at infoworld about this?
(Assignee)

Comment 7

18 years ago
ok, this problem is widespread enough that I decided to spend some time on it.
IE and Nav both stack floaters horizontally instead of pushing them down
veritcally as per CSS spec.  I talked to some friends at a couple of web design
firms, and they seem to think this is a pretty common pattern:  hoizontally
stacking tables/images with the HTML align attribute and expecting them to all
be on the same line.  So, I have a fix in hand where in quirks mode ONLY we
always horizontally stack floaters.

nominating for nsbeta2. The fix is to simply skip the code that pushes floaters
down in quirks mode.
Severity: normal → major
Keywords: nsbeta2
Priority: P3 → P1
Whiteboard: fix in hand
Target Milestone: --- → M17
(Assignee)

Comment 8

18 years ago
*** Bug 30990 has been marked as a duplicate of this bug. ***
Recommend [nsbeta2+][6/15].

Updated

18 years ago
Whiteboard: fix in hand → [nsbeta2+] [6/15] fix in hand
(Assignee)

Comment 10

18 years ago
changed the summary and added 4xp since this is entirely a quirks issue.
Keywords: 4xp
Summary: Layout of Infoworld columns wrong .... may be table related → floaters should stack horizontally in compat mode
compat is for quirks issues: 4xp is for issues that were _correct_ in legacy
browsers but which we get wrong, whereas compat is for isses that were wrong in 
legacy browsers and which we get right.
Keywords: 4xp → compat
(Assignee)

Comment 12

18 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta2+] [6/15] fix in hand → [nsbeta2+] [6/15]
Does this quirk exist in older browsers for all elements, or just tables?  What 
are we doing?

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 14

18 years ago
Test case supplied is rendering correctly. Fixed in the June 19th build 
(20000061908).
*** Bug 41795 has been marked as a duplicate of this bug. ***
*** Bug 32667 has been marked as a duplicate of this bug. ***
For reference, bug 43086 is about fixing the fix to this bug.
You need to log in before you can comment on or make changes to this bug.