Status

()

Firefox
General
RESOLVED DUPLICATE of bug 142089
11 years ago
11 years ago

People

(Reporter: Mark Graham, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

<input type="image"> should NOT be submitted with a form if it were to have value="foo" appended. Firefox is the only browser which submits form data from this type of input.

Example:

<input type="image" src="baz.jpg" name="foo" value="bar"> will submit foo as bar in Firefox. But in all other browsers I tried it in, it won't.

Reproducible: Always

Steps to Reproduce:
Submit a form with <input type="image" src="image.jpg" name="foo" value="var"> init.
Actual Results:  
It was submitted.

Expected Results:  
Not be submitted.
This is by design and fits the html specification
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 142089
You need to log in before you can comment on or make changes to this bug.