Last Comment Bug 376636 - Building with GCC-4.3 and '-pedantic' fail due to extra semi-colons and missing newlines
: Building with GCC-4.3 and '-pedantic' fail due to extra semi-colons and missi...
Status: RESOLVED FIXED
: fixed1.8.1.22
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 408238
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-05 12:12 PDT by Art Haas
Modified: 2009-04-07 01:03 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Compressed patchset removing ':' and adding missing newline (25.58 KB, application/x-gzip)
2007-04-05 12:14 PDT, Art Haas
no flags Details
Second patch removing more extra ';' (2.07 KB, patch)
2007-04-06 12:31 PDT, Art Haas
no flags Details | Diff | Splinter Review
Compress patch file (25.95 KB, application/x-gzip)
2007-04-22 11:27 PDT, Art Haas
no flags Details

Description Art Haas 2007-04-05 12:12:35 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070405 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070405 SeaMonkey/1.5a

Hi.

The development version of GCC has changed various warnings to errors if the '-pedantic' flag is used. Numerous files in the Mozilla tree have extra ';' characters and at least one file does not end with a newline. These problems now result in build failures.

Reproducible: Always

Steps to Reproduce:
1. Install GCC-4.3 development snapshot
2. Try to build Mozilla/SeaMonkey/Firefox
3. See build go boom!
Actual Results:  
 Build failed. :-(

Expected Results:  
 Build succeeds: :-)

I will attach a large patch that fixed the build problems on my machine (Fedora Rawhide and GCC-4.3 from 04/04/07).
The patch touches a large number of files in various directories, but the majority of the individual patches are usually just a few lines long and are the removal of ';' characters.
Comment 1 Art Haas 2007-04-05 12:14:39 PDT
Created attachment 260749 [details]
Compressed patchset removing ':' and adding missing newline

Here are the patches.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2007-04-05 12:17:22 PDT
Could you make that one big patch (use cvs diff -u) and attach the patch file instead of a tar?  It's much easier to take a look at that way.

Comment 3 Art Haas 2007-04-05 12:30:08 PDT
Hi.

My attachment is a single file. My description above is not clear when I read now what I wrote a couple of minutes ago. Sorry about that. The 'diffs.gz' file is the output of a 'cvs diff -u' command as you suggested.
Comment 4 Art Haas 2007-04-06 12:31:28 PDT
Created attachment 260846 [details] [diff] [review]
Second patch removing more extra ';'

In the initial patch I removed some other changes that are in my tree and carelessly removed these changes to three other files needing editing. This patch contains the fixes for these three files.
Comment 5 Art Haas 2007-04-22 11:27:01 PDT
Created attachment 262444 [details]
Compress patch file

Here's an updated patch based on the tree from a day or two ago. The patch is a single file containing the output of 'cvs diff -u' and it is compressed due to size.
Comment 6 Benjamin Smedberg [:bsmedberg] 2007-04-23 07:58:50 PDT
Fixed on trunk (rs=me)
Comment 7 Simon Montagu :smontagu 2009-04-07 01:03:44 PDT
Checked in to 1.8 branch (with bug 317216)

Note You need to log in before you can comment on or make changes to this bug.