Long URL doesn't provide the same results in Mozilla as in Netscape 4.7 and IE

VERIFIED FIXED

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Henrik Gemal, Assigned: Gagan)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
If you go to this URL:
http://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bu
g_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&email1=&emailtype1=sub
string&emailassigned_to1=1&email2=&emailtype2=substring&emailreporter2=1&bugidty
pe=include&bug_id=&changedin=1&votes=&chfield=%5BBug+creation%5D&chfieldfrom=&ch
fieldto=Now&chfieldvalue=&product=Browser&product=MailNews&short_desc=&short_des
c_type=substring&long_desc=&long_desc_type=substring&bug_file_loc=&bug_file_loc_
type=substring&status_whiteboard=&status_whiteboard_type=substring&keywords=&key
words_type=anywords&field0-0-0=noop&type0-0-0=noop&value0-0-0=&cmdtype=doit&newq
ueryname=&order=Reuse+same+sort+as+last+time

the order of the bugs are ont the same in Mozilla as in Netscape 4.7 and IE

I haven't had the time to debug where it goes wrong in the URL.

Build 2000042808
(Reporter)

Comment 1

18 years ago
Adding URL field
(Assignee)

Comment 2

18 years ago
yes that is because you are requesting the order from a parameter which says
order=Reuse+same+sort+as+last+time I am not sure how that part is implemented
(my guess would be cookies) cc'ing bugzilla guru for comments and marking this
bug as invalid.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
Yes, it's a cookie.
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 4

18 years ago
It gives different results even without the "order" parameter.

Comment 5

18 years ago
Yes, because the default value of the order is "reuse the last order".  So,
removing the order from the URL shouldn't change anything.
(Reporter)

Comment 6

18 years ago
Ok. Thanx for the info. Resolving as fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
verifying using 2000062520 nightly on w2k
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.