Tab key skips to next field on textarea

VERIFIED DUPLICATE of bug 2642

Status

()

P3
normal
VERIFIED DUPLICATE of bug 2642
19 years ago
19 years ago

People

(Reporter: simon.britnell, Assigned: joki)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12-20 i686; en-US; m16) Gecko/20000428
BuildID:    2000042809

When entering information into a textarea control, the tab key inserts a tab and
skips to the next field.

Reproducible: Always
Steps to Reproduce:
1.browse to page
2.click in a text area (not the last one on the page)
3.type in some text
4.click to position cursor between two letters(so you may see the tab inserted)
5.press tab key


Actual Results:  Tab inserted between the two characters and cursor jumps to
next field.

Expected Results:  Cursor does not jump to next field.

Comment 1

19 years ago
Bug 2642 describes the problem with mozilla currently trying to do both.  Then 
there's bug 18934 (tab should switch fields) vs. bug 29086 (tab should insert a 
tab character, at least one mac).

*** This bug has been marked as a duplicate of 2642 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.