Last Comment Bug 376777 - data for "text/uri-list" flavor set in nsIClipboardDragDropHooks::OnCopyOrDrag() is overridden in nsDragService::SourceDataGet()
: data for "text/uri-list" flavor set in nsIClipboardDragDropHooks::OnCopyOrDra...
Status: RESOLVED FIXED
: fixed1.8.1.18
Product: Core
Classification: Components
Component: Drag and Drop (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: ---
Assigned To: Tobias Koenig
:
: Neil Deakin
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-07 06:08 PDT by Tomeu Vizoso
Modified: 2008-10-21 14:45 PDT (History)
8 users (show)
dveditz: wanted1.8.1.x+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for only set text/uri-list from x-moz-url when no uri-list has been explicitly set [Checkin: Comment 5] (2.18 KB, patch)
2007-04-07 06:18 PDT, Tomeu Vizoso
roc: review+
roc: superreview+
Details | Diff | Splinter Review
Backport for 1.8 branch (3.26 KB, patch)
2008-09-25 02:25 PDT, Tobias Koenig
dveditz: approval1.8.1.18+
Details | Diff | Splinter Review

Description Tomeu Vizoso 2007-04-07 06:08:22 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.2) Gecko/20060601 Firefox/2.0.0.2 (Ubuntu-edgy)
Build Identifier: 

If I add a "text/uri-list" flavor to the nsITransferable passed in nsIClipboardDragDropHooks::OnCopyOrDrag(), nsDragService::SourceDataGet() in gtk2 will override that with the contents in the "text/x-moz-url" flavor.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Tomeu Vizoso 2007-04-07 06:18:18 PDT
Created attachment 260884 [details] [diff] [review]
Patch for only set text/uri-list from x-moz-url when no uri-list has been explicitly set
[Checkin: Comment 5]
Comment 2 Adam Guthrie 2007-04-07 16:33:46 PDT
You'll need to ask someone to review the patch if you want it to be included in the main tree. See http://www.mozilla.org/owners.html for help with finding the correct reviewer.
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2007-04-09 22:11:43 PDT
Comment on attachment 260884 [details] [diff] [review]
Patch for only set text/uri-list from x-moz-url when no uri-list has been explicitly set
[Checkin: Comment 5]

thanks!!!
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2007-04-09 22:13:14 PDT
We'll take this on trunk in our tree. We need to discuss whether it should be on branch; it doesn't meet normal branch criteria but as it's Linux-only there's some flexibility here.
Comment 5 Marco Pesenti Gritti 2007-04-11 02:06:57 PDT
Landed on the trunk:

cvs commit: Examining widget/src/gtk2
Checking in widget/src/gtk2/nsDragService.cpp;
/cvsroot/mozilla/widget/src/gtk2/nsDragService.cpp,v  <--  nsDragService.cpp
new revision: 1.14; previous revision: 1.13
done
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-04-12 11:19:45 PDT
Is there any reason for this bug to still be open?
Comment 7 Marco Pesenti Gritti 2007-04-12 15:17:35 PDT
I left it open because of comment #4.

I don't have a strong feeling and I don't know what are the criteria to land on the branch. Tomeu wrote the patch for OLPC and we are going to use 1.9 there anyway. Though the bug was confusing enough that fixing it might be useful for other embedders on 1.8.
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-04-13 20:06:23 PDT
Ah, OK. Branch status doesn't have anything to do with the resolution (we use keywords for that), so I'll mark this FIXED.
Comment 9 Tobias Koenig 2008-09-25 02:25:22 PDT
Created attachment 340312 [details] [diff] [review]
Backport for 1.8 branch

This bug prevents some other code from working correctly and there is no way to circumwent it in higher levels of code, so can that patch be applied to the branch, please?
As it is 'only' for Linux it can't break that much (under the viewpoint that drag'n'drop doesn't work correctly without that patch anyway) ;)

Ciao,
Tobias
Comment 10 Tobias Koenig 2008-09-25 02:51:05 PDT
Comment on attachment 340312 [details] [diff] [review]
Backport for 1.8 branch

Sorry, wrong branch :}
Comment 11 Daniel Veditz [:dveditz] 2008-10-01 14:57:31 PDT
Comment on attachment 340312 [details] [diff] [review]
Backport for 1.8 branch

Approved for 1.9.0.4, a=dveditz for release-drivers
Comment 12 Daniel Veditz [:dveditz] 2008-10-15 10:17:01 PDT
meant approved for 1.8.1.18, like the flag setting.
Comment 13 Daniel Veditz [:dveditz] 2008-10-20 18:29:09 PDT
Fix checked into the 1.8 branch
Comment 14 Al Billings [:abillings] 2008-10-21 14:45:08 PDT
Is there a good repro case to verify this fix and the previous problem?

Note You need to log in before you can comment on or make changes to this bug.