Strip out some un-needed rules from Camino-only forms.css

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: stuart.morgan+bugzilla, Assigned: jaas)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

v2
1.38 KB, patch
jaas
: review+
dbaron
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
Created attachment 261216 [details] [diff] [review]
cleanup

I went through the rules in the Camino-only section of forms.css and pulled out a few that no longer appear to be necessary given the current state of trunk. This should make it a bit easier to see what's left to implement in the theme code so we can eventually rip the rest out without causing regressions.
Attachment #261216 - Flags: review?(joshmoz)
(Assignee)

Comment 1

12 years ago
Comment on attachment 261216 [details] [diff] [review]
cleanup

Fine with me if it doesn't make camino unusable - the smaller the CSS diff between camino and Firefox the better.
Attachment #261216 - Flags: review?(joshmoz) → review+

Comment 2

12 years ago
While you are at it, you could also remove the background-color rule from
input,
input[disabled] {
  padding: 0px 1px 0px 1px;
  font-size: 11px;
  margin: 1px 1px 1px 1px;
  background-color: -moz-field;
}

That one line causes disabled textfields to paint as gfx, for which I just filed bug 377124.
(Reporter)

Comment 3

12 years ago
Created attachment 261258 [details] [diff] [review]
v2

Yep, thanks. I thought I tried that and ended up with transparent fields, but apparently not since it works for me now.
Attachment #261216 - Attachment is obsolete: true
Attachment #261258 - Flags: review?(joshmoz)
(Assignee)

Updated

12 years ago
Attachment #261258 - Flags: review?(joshmoz) → review+
(Reporter)

Updated

12 years ago
Attachment #261258 - Flags: superreview?(dbaron)
Attachment #261258 - Flags: superreview?(dbaron) → superreview+
(Reporter)

Comment 4

12 years ago
Landed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Blocks: 377124
You need to log in before you can comment on or make changes to this bug.