Closed Bug 377311 Opened 14 years ago Closed 14 years ago

Should be able to rank helpfulness of bug comments and hide unhelpful ones

Categories

(Bugzilla :: Creating/Changing Bugs, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 180040

People

(Reporter: 4aeikob02, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

There are a lot of Firefox bugs that everyone wants to be fixed but which no one ever fixes.  Of course this leads to a lot of people coming onto Bugzilla and whining about it.  "This has been unfixed for five years!  Why hasn't anyone fixed it!?"  Then the developers come in and say "Stop cluttering up the bug report with advocacy comments!  We're going to withhold the fix just to spite you for annoying us!"  etc. etc. etc.  The back and forth completely buries the actually relevant comments.

There should be a way to moderate comments by voting for them, like Slashdot or digg.  Unhelpful comments (advocacy, anti-advocacy, and other discussions not actually relevant to fixing the bug) will be hidden by default, and helpful comments shown.  Maybe *very* helpful comments (this is the patch that seems to fix it) will be highlighted more than the regular ones.

You would be able to unhide individual comments of course, and maybe have "thresholds" like Slashdot.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The biggest problem that I see with this proposal is that the same people who
come in and whine about a lack of progress would be likely to give high ratings
to all of the other whining comments.  (Maybe this would work out if you
limited moderation to users with canconfirm or maybe editbugs privileges, but then you'd start to worry about the community being too small for the moderation to be impartial or even visible.)  On another note, I seem to recall a suggestion in the past to actually include a specific label for "advocacy" comments (or even a separate list for them), but I don't know offhand whether there's a bug for it.

(Also, whether this is the right approach or not, I've generalized the platform
and OS fields: this clearly isn't PC only!)
OS: Windows XP → All
Hardware: PC → All
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 180040
You need to log in before you can comment on or make changes to this bug.