The default bug view has changed. See this FAQ.

Only display focus outline after tab key has been pressed

RESOLVED DUPLICATE of bug 418521

Status

()

Core
Keyboard: Navigation
--
enhancement
RESOLVED DUPLICATE of bug 418521
10 years ago
3 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
It appears that IE7 only shows the focus outline for focusable elements after the tab key has been pressed at least once.

So clicking on a link for example, doesn't show a focus outline, but after you've pressed the tab key and then clicked on the link, then the focus outline on the link is showed.

Maybe Firefox should do the same?

Comment 1

10 years ago
It also appears as if IE7 resets the "show outline" state every time
a different window is focused.  This reset also occurs if I change the
window focus using the keyboard only.
Severity: normal → enhancement
The dotted outline is always handy when you want to see the last clicked link on sites without marked visited links e.g. www.nu.nl.
(Reporter)

Comment 3

10 years ago
Yeah, Ria is right.
When you click back in IE7, the last link you clicked upon has still the active state, so you know what link you clicked last upon in IE7, too.
If we want this changed, then we need to make sure there is still a visual way to know what link was clicked upon when going back.
Duplicate of this bug: 399743
(Reporter)

Updated

9 years ago
Blocks: 418521

Updated

8 years ago
No longer blocks: 418521
Depends on: 418521
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 418521
Resolution: --- → DUPLICATE
Duplicate of bug: 418521
You need to log in before you can comment on or make changes to this bug.