Closed Bug 377345 Opened 15 years ago Closed 15 years ago

Kannada Unicode font is not displayed properly.

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 218887

People

(Reporter: prasadvenkatesh, Unassigned)

References

()

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Web site written in Unicode is rendered properly.
If I open the same website in IE (Internet explorer it opens correctly)
Of course I had to download usp10.dll and put it under IE folder "C:\Program Files\Internet Explorer" in order to render  the same website correctly in IE.
But I tried putting that also under Firefox folder "C:\Program Files\Mozilla Firefox" but it does not help.

Reproducible: Always

Steps to Reproduce:
1. Install Mozilla Firefox any version on Windows 2000 OS
2. Open Firefox browser.
3. Go to the web site http://www.kannadalyrics.com/
4. See the font is rendered incorrectly.
5. Open Internet Explorer browser (on same windows 2000 OS).
6. Go to the web site http://www.kannadalyrics.com/
7. See the font might not have rendered incorrectly.
8. Copy the USP10.DLL that comes with windows XP to "C:\WINNT\System32" directory and also to directory "C:\Program Files\Internet Explorer"
9. Go to the web site http://www.kannadalyrics.com/
10. See the font rendered correctly.
11. Copy the USP10.DLL that comes with windows XP to "C:\Program Files\Mozilla Firefox"
12. See the font is rendered incorrectly. like "ಕವನ ಸಂಕಲನ- ದೀಪದ ಮಲ್ಲಿ"
Actual Results:  
Website Unicode font cannot be read since not rendered correctly.

Expected Results:  
Website Unicode font should have been rendered correctly.
Summary: Unicode font is not displayed properly. → Kannada Unicode font is not displayed properly.
Screen shot image of the website rendered in IE
Firefox displays incorrect Unicode cannot be read.
Makes Firefox unusable.
Read:
https://bugzilla.mozilla.org/show_bug.cgi?id=218887#c2

I suggest this bug be marked duplicate of #218887
I agree :)

Unfortunately I can't read Kannada, but on trunk builds the site seems to look like the "correct" screen shot
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: uniscribe
You need to log in before you can comment on or make changes to this bug.