Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Web Page Scaling issues (ctrl +) when using a widescreen monitor

RESOLVED DUPLICATE of bug 4821

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 4821
10 years ago
10 years ago

People

(Reporter: Keith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; InfoPath.2; FDM)
Build Identifier: 2.0.0.3

At certain web pages, for example http://www.dpreview.com/ the entire web page is displayed on only the left 25% of the monitor. 

Trying to correct this by using ctrl+ fails and the page becomes unreadable

This problem does not exist in Internet Explorer (ctrl+ scales the page properly)

Reproducible: Always

Steps to Reproduce:
1. enter into a webpage with the issue (http://www.dpreview.com/)
2. use a widescreen monitor. (2560x1600)
3. press ctrl+ repeatedly
Actual Results:  
using a widescreen monitor the page occupies 25% of one side of the screen and the text is very small

Expected Results:  
1. the software should have scaled the entire web page up, instead of simply increasing the text size

2. Ideally ctrl+ should not have to be used at all, the page should scale to your display

I can provide screenshots if necessary

monitor: 2560x1600
OS: Vista

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-official-branding --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-update-packaging

Comment 1

10 years ago
It looks like it's a fixed width layout so page zoom is needed.  Which that's bug 4821.  

>Ideally ctrl+ should not have to be used at all, the page should scale to
your display

That's up to the web page designer.  Usually fixed width layouts are used to avoid long lines of text which are hard to read.  The future solution to this is to use CSS columns.  Mozilla has some support for this but I don't know of other browsers that do.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 4821
You need to log in before you can comment on or make changes to this bug.