Need to add an alerting service when user log on

RESOLVED DUPLICATE of bug 130835

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED DUPLICATE of bug 130835
11 years ago
11 years ago

People

(Reporter: Romain Pelissier, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)
Build Identifier: 3.0rc1

One thing that is currently missing (or maybe I haven't see this option yet?) is a way to display some alert when a user log on.
What alert I am talking about?
In fact, when a bug require an action from a reporter (or other user invvolved with the bug resolution) actually he is informed about what he did (create new a bug) what he need to do (when a bug has been updated with a request info or when the whineatnews script send by email some task to do).
It's cool but it is sometimes not enough : if you have bugzilla installedwith no email option set, there is no way to know for a user if he need to perfom some action of some bugs until ghe perfom a query)

Another reason to add an alerting system when the user log on is the fact that in the 3.0rc version there are some fields when a user can tell how long time he expect to close a bug, when the bug has been created and when it is closed. With an alerting system directly displayed at logon, I think that the resolution time could be shorten and the stats that you could make wirth those information could greatly improve the usuability of bugzilla.

The alert may required some modification to the UI as some modifs to the DB itself. But it could be very nive to have some Task list to be displayed in some ways to inform the user what he need to do, other than just being altered by email. (email is good of course and the whineanews script is a nive tool also but is in some situation it is not really convenient.
So the alerts system could be an pseudo emailing system where the tasks can be displayed when the user log on.

I think it could be a very nice feature to add to bugzilla. What to you think?

Reproducible: Always

Steps to Reproduce:
1. No email option is set
2.
3.
Actual Results:  
If no email option are set, it is quite difficult to know what a user need to do with its bugs unless toy create a query for that

Expected Results:  
When the user log on, a 'task to do' could ne displayed with bug numbers and action to perfom.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 130835
You need to log in before you can comment on or make changes to this bug.