Color stays in view when deselecting 'use color' in sunbird.

VERIFIED FIXED

Status

Calendar
Calendar Views
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Fallen, Assigned: Fallen)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.4pre) Gecko/20070415 Calendar/0.5pre

Steps:
* Set a color for a category
* Create an event with this category.
* Remove the color from the category.

Result:
* The colored border stays, even if the view is refreshed.
(Assignee)

Comment 1

11 years ago
Created attachment 261664 [details] [diff] [review]
Fix getPrefSafe

I have tracked down the Problem.

* getPrefSafe throws NS_ERROR_UNEXPECTED in [1], the rule is never deleted.
* nsIPrefBranch::clearUserPref() [2] says it will delete the preference if there is no default value, but it doesn't until you restart the application. The preference stays with a null default value, which throws the above NS_ERROR.
* The issue is fixed on trunk in bug 193332. This means we need to work around it.
* The attached patch should function as a workaround.

[1] http://mxr.mozilla.org/mozilla1.8/source/calendar/base/content/calendar-views.js#316
[2] http://mxr.mozilla.org/mozilla1.8/source/modules/libpref/public/nsIPrefBranch.idl#209
Assignee: nobody → bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #261664 - Flags: first-review?(jminta)

Comment 2

11 years ago
Comment on attachment 261664 [details] [diff] [review]
Fix getPrefSafe

See also bug 340229.
Attachment #261664 - Flags: first-review?(jminta) → first-review+
(Assignee)

Comment 3

11 years ago
This bug is rather visible and the patch is quite harmless. Therefore, I'm requesting blocking.
Flags: blocking-calendar0.5?

Comment 4

11 years ago
The fix in this patch is the same as in Bug 372626.

Comment 5

11 years ago
This can be checked in, as per the conference call.
Flags: blocking-calendar0.5? → blocking-calendar0.5+
(Assignee)

Comment 6

11 years ago
Checked in on MOZILLA_1_8_BRANCH and HEAD.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Duplicate of this bug: 372626
(Assignee)

Comment 8

11 years ago
verified on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.4pre) Gecko/20070426 Calendar/0.5pre
Status: RESOLVED → VERIFIED

Comment 9

11 years ago
Litmus testcase 2625 created

Updated

10 years ago
Flags: blocking-calendar0.5+
You need to log in before you can comment on or make changes to this bug.