If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CSS2.1 changed behavior of formatting context roots next to floats

RESOLVED FIXED in mozilla1.9

Status

()

Core
Layout: Block and Inline
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: bz, Assigned: dbaron)

Tracking

Trunk
mozilla1.9
Points:
---
Bug Flags:
blocking1.9 -
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

See http://lists.w3.org/Archives/Public/www-style/2007Apr/0040.html item 2.

This basically changes what we do with available width, as well as the actual positioning of the blocks in question....

Assuming this change is here to stay we should probably fix it for 1.9 if we can.
Flags: blocking1.9?
To what extent do we already implement this?
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-1.9]
I think we implement what the spec used to say, more or less.  That is, we make the margin-box not overlap floats.  The change is that now it's the border-box....
Ah, right, that part of the change.
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
Note that bug 427129 (which is basically a duplicate of this) is a blocker for now.
Blocks: 427129
So we'd basically need to change OneWidthToClearPastFloats() to not include margins.  And what else?
OS: Linux → All
Hardware: PC → All

Updated

10 years ago
Duplicate of this bug: 428634
Patch in progress in bug 427129.
Assignee: nobody → dbaron
Fixed by checkin of bug 427129 to trunk, 2008-04-14 18:06 -0700.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9
You need to log in before you can comment on or make changes to this bug.