Can't tab to addr. bar; select-all doesn't happen on focus

VERIFIED DUPLICATE of bug 28583

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 28583
18 years ago
14 years ago

People

(Reporter: Stanton McCandlish, Assigned: asa)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I've been using Mozilla M15 on a beige G3. (I can't set the version properly 
with the form; *right now* I'm using IE4.5, and for whatever reason the only 
version available in this form under this browser is "other".)

This is to confirm that the bugs reported in 36278 (and possibly 28583 if you 
view that bug as a generalizable report of text not being 
highlighted/select-all'd when you tab to or otherwise shift focus to it) are 
also present under MacOS 9 (and presumably 8).

There are two probalby closely related bugs:

1) Tabbing in the browser window does not get you into the address bar 
(eventually - you might have to tab thru several fields if the page contains a 
form, for exmaple).

2) Shifting focus to a text area doesn't select-all (hightlight) the text for 
replacement (this should happen more generally. 28583 reports this problem in a 
completely different part of the interface, while 33069 reports it for the 
address bar, but in relation to tabbing as well as mouseclicking into the 
address bar, which implies that bug 1, above, may not apply to Windows NT (the 
OS used by the reporter of 33069).

I would add that Reuben's comment, from the duplicate [of 31809, not THIS bug 
report, 36278] bug 33069 is somewhat wide of the mark:
"I sugges having an Interface like IE 5, that lets you use ALT+D to move the
focus to the Location Bar, and highlight all the contents as well. I use this
very often, and find it a very useful feature."  

That's all well and good for Windows users, but "Alt-D" wouldn't make any sense 
at all to a Mac user.  I think what's called for is *behavior as consistent as 
possible with other browsers*.  On a Mac this means that hitting tab anywhere in 
a browser window moves from field to field, including form fields and
(Reporter)

Comment 1

18 years ago
Relocating this to XP Toolkit/Widgets, which the description says includes focus 
issues
Component: Browser-General → XP Toolkit/Widgets
(Assignee)

Comment 2

18 years ago
bug 31809 or bug 28583.

*** This bug has been marked as a duplicate of 28583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 4

18 years ago
yep, 28583

verif.
Status: RESOLVED → VERIFIED

Updated

14 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.