Add support for submission @standalone attr for serialization

RESOLVED FIXED

Status

Core Graveyard
XForms
--
enhancement
RESOLVED FIXED
10 years ago
11 months ago

People

(Reporter: Steve Speicher, Assigned: Steve Speicher)

Tracking

({fixed1.8.0.12, fixed1.8.1.4})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

1.79 KB, application/xhtml+xml
Details
1.06 KB, patch
aaronr
: review+
Doron Rosenberg (IBM)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 

In updated W3C test case 3.3.3.j

Reproducible: Always
(Assignee)

Comment 1

10 years ago
Created attachment 261951 [details]
test case
(Assignee)

Comment 2

10 years ago
Created attachment 262161 [details] [diff] [review]
patch

This doesn't fix the test case as-is, as I believe there is a problem with the test suite case (I'll address that with owner).

It appears that standalone="true" should include *standalone="yes"* declaration, as I read:
  "Optional attribute specifying whether to include a standalone declaration in the serialized XML."

So I guess there is no way to explicitly make *standalone="no"*.  Or what is the default if standalone is omitted?  formsPlayer uses *standalone="yes"* if true or omitted, if false uses *standalone="no"*.

I've taken the route which I believe is what was intended.  If false (the default) omit, otherwise if true add declaration *standalone="yes"*
(Assignee)

Updated

10 years ago
Attachment #262161 - Flags: review?(aaronr)

Comment 3

10 years ago
Comment on attachment 262161 [details] [diff] [review]
patch

I interpret it the same way you do.
Attachment #262161 - Flags: review?(aaronr) → review+
(Assignee)

Updated

10 years ago
Attachment #262161 - Flags: review?(doronr)

Updated

10 years ago
Attachment #262161 - Flags: review?(doronr) → review+

Updated

10 years ago
Assignee: xforms → sspeiche
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

10 years ago
checked into trunk, 1.8 and 1.8.0 branches
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.8.0.12, fixed1.8.1.4
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.