Closed Bug 377966 Opened 15 years ago Closed 14 years ago

Odd alignment of radio button internal elements on Page Setup dialog

Categories

(Toolkit :: Printing, defect)

x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED FIXED
mozilla1.9beta3

People

(Reporter: mcdavis941.bugs, Assigned: wladow)

Details

(Keywords: polish)

Attachments

(3 files, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

On the Page Setup dialog, with the default theme, radio buttons for portrait/landscape line up a little funny.  

Adding some CSS to printPageSetup.css corrects this.  The attachment shows before and after screenshots, or see http://img136.imageshack.us/img136/8977/pagesetupcssti2.jpg .
 
This CSS added to printPageSetup.css does the trick.
 
Before:
=======
 
.portrait-page {
  list-style-image: url("chrome://global/skin/icons/Portrait.png");
}

.landscape-page {
  list-style-image: url("chrome://global/skin/icons/Landscape.png");
}

After:
======
 
.portrait-page {
  list-style-image: url("chrome://global/skin/icons/Portrait.png");
}
 
.landscape-page {
  list-style-image: url("chrome://global/skin/icons/Landscape.png");
}
 
.radio-label-box {
  -moz-box-align: center;
}

Maybe -moz-box-align: center would be better added to radio.css for all .radio-label-box elements, but I haven't looked into that.
 


Reproducible: Always

Steps to Reproduce:
1. Just open the dialog and look at it
Component: General → Printing
Product: Firefox → Toolkit
QA Contact: general → printing
Version: unspecified → 1.8 Branch
I don't see an obvious dupe, so confirming. I also see this on trunk using Windows XP.

Reporter, if you're up for making a patch, that'll make it easier to get this bug fixed. See: http://developer.mozilla.org/en/docs/Creating_a_patch
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
OS: Windows 98 → Windows XP
Version: 1.8 Branch → Trunk
Attached patch Toolkit patch (obsolete) — Splinter Review
Assignee: nobody → valastiak
Status: NEW → ASSIGNED
Attachment #295955 - Flags: review?(mano)
Attached patch SeaMonkey Modern theme patch (obsolete) — Splinter Review
Attachment #295956 - Flags: review?
Robert can probably direct you to someone who can do the SeaMonkey modern review.
Comment on attachment 295956 [details] [diff] [review]
SeaMonkey Modern theme patch

Neil, the "SeaMonkey UI tsar" (see http://www.seamonkey-project.org/dev/project-areas), is probably the best reviewer for Modern.
Attachment #295956 - Flags: review? → review?(neil)
Comment on attachment 295956 [details] [diff] [review]
SeaMonkey Modern theme patch

This needs to be in radio.css
Attachment #295956 - Flags: review?(neil) → review-
Attached patch SeaMonkey Modern theme patch v2 (obsolete) — Splinter Review
Moving code into radio.css per comment #7
Attachment #295956 - Attachment is obsolete: true
Attachment #295978 - Flags: review?(neil)
Actually, would we be better off putting the align in the XBL instead?
Comment on attachment 295978 [details] [diff] [review]
SeaMonkey Modern theme patch v2

Yeah, this needs to go into radio.xml instead. Sorry to mess you around like this.
Attachment #295978 - Flags: review?(neil) → review-
Attachment #295955 - Attachment is obsolete: true
Attachment #295955 - Flags: review?(mano)
Besides radio.xml also /winstripe/global/globalBindings.xml needs to be patched as it extends radio.xml. Patch was tested on WinVista with Firefox and SeaMonkey nightlies. Works fine with both default and modern theme.
Attachment #295978 - Attachment is obsolete: true
Attachment #296859 - Flags: review?(neil)
Comment on attachment 296859 [details] [diff] [review]
patch for radio.xml and globalBindings.xml

Nit: it seems to be more common to put the align between the class and the flex.
Attachment #296859 - Flags: review?(neil) → review+
Attachment #296859 - Flags: approval1.9?
this is a patch with comment #12 applied
Attachment #296859 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in toolkit/content/widgets/radio.xml;
/cvsroot/mozilla/toolkit/content/widgets/radio.xml,v  <--  radio.xml
new revision: 1.28; previous revision: 1.27
done
Checking in toolkit/themes/winstripe/global/globalBindings.xml;
/cvsroot/mozilla/toolkit/themes/winstripe/global/globalBindings.xml,v  <--  globalBindings.xml
new revision: 1.14; previous revision: 1.13
done
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M11
You need to log in before you can comment on or make changes to this bug.