Closed Bug 378061 Opened 15 years ago Closed 14 years ago

Cursor is placed incorrectly in Rich Text areas when the last character is a "space"

Categories

(Core :: DOM: Editor, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: apedralho, Unassigned)

References

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3) Gecko/20070322 GranParadiso/3.0a3

In the DesignMode if I write some text finalized with a space it is not shown when the focus is lost and return from/to the text area.

Reproducible: Always

Steps to Reproduce:
1. Write some text in a rich text area and add a space after the text
2. Click outside the text area (it should lose the focus)
3. Click inside the text area (after the space previously written)
Actual Results:  
The cursor is placed after the text, before the space.

Expected Results:  
The cursor is placed after the space.
By reporting it with 3.0a3, but against 2.0, did you mean that it works in 3.0a3?
Component: General → Editor
Product: Firefox → Core
QA Contact: general → editor
Version: 2.0 Branch → 1.8 Branch
No. It works in 2.0 but doesn't in 3.0a3.
I'm pretty sure this could be considered a duplicate of bug 336408.
I think they have the same solution. I mean, when the bug #336408 has been fixed this bug would be fixed too.
Depends on: 336408
Version: 1.8 Branch → Trunk
Andre, has this become worksforme, now?
It is working fine using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.