Closed Bug 378119 Opened 13 years ago Closed 12 years ago

unexpected space before auto-appended mnemonic on localized menu labels.

Categories

(Mozilla Localizations :: ko / Korean, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cwryu, Assigned: channy)

Details

(Keywords: verified1.8.1.10)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; ko-KR; rv:1.8.1.3) Gecko/20070310 Iceweasel/2.0.0.3 (Debian-2.0.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; ko-KR; rv:1.8.1.3) Gecko/20070310 Iceweasel/2.0.0.3 (Debian-2.0.0.3-2)

The Korean langpack never specifies menu mnemonics but there're mnemonics on every menu labels.  I guess some code inserts mnemonics with parentheses  (such like "File (_F)") to the menu labels when they don't have their own mnemonics.

The problem is, it appends mnemonic text such like " (_F)" with a space between the labels and opening parentheses.

But this is different with the convention other Korean applications (in MS-Windows/GNOME/KDE/...) are using.  Those applications don't use space between the label and opening parentheses.  Their labels just look like "File(_F)" without space.

I don't know what convention is used for other languages.  But at least in Korean desktop, Firefox looks a bit inconsistent because of this different menu mnemonic convention.


Reproducible: Always

Steps to Reproduce:
1. Start firefox with Korean locale.
2. Compare its menubar with other Korean app's menubar.
Does this happen with an official Firefox build from mozilla.com? This sounds like something that the distribution might change...
Whiteboard: CLOSEME - 06/15
Iceweasel has no such changes. I also use an "official" firefox in MS Windows and its menu labels have the same problem.
Whiteboard: CLOSEME - 06/15
Is this something that's okay to fix?
I found this can be fixed in the Korean lang pack.  By setting the default value of intl.menuitems.insertseparatorbeforeaccesskeys as false.  (There seem to be some languages which require it?)

Moving this bug to ko-KR localization product...
Component: Menus → ko-KR / Korean
Product: Firefox → Mozilla Localizations
Assignee: nobody → channy
QA Contact: menus → admin
(In reply to comment #4)
> I found this can be fixed in the Korean lang pack.  By setting the default
> value of intl.menuitems.insertseparatorbeforeaccesskeys as false.  (There seem
> to be some languages which require it?)
> 
> Moving this bug to ko-KR localization product...
> 

This bug was old problem. Comparing with ja code, its value must be false.
http://lxr.mozilla.org/l10n-mozilla1.8/source/ja/toolkit/chrome/global/intl.properties

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #288303 - Flags: approval1.8.1.11?
Comment on attachment 288303 [details] [diff] [review]
intl.properties patch

[ko] approving accesskey space removal for 1.8.1.10, please use the fixed1.8.1.10 and verified1.8.1.10 keywords to track landing and testing.
Attachment #288303 - Flags: approval1.8.1.11? → approval1.8.1.10+
fixed in 1.8.1 branch.
Keywords: fixed1.8.1.10
fixed in 1.9 trunk too.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.