Open Link New Tab Restriction

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: brianf1980, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bugday0420, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1

In the console, the "browser.link.open_newwindow.restriction" should have a value of 2.When a user has the preference for opening links in new tabs, It shouldnt apply to javascript windows. JS windows usually have a unique size, but with the openlink to new tab is checked,the js windows looks very odd.

Set to value 2 in console to resolve.

Reproducible: Always

Steps to Reproduce:
1. Enable "Open Links to New Tabs"
2.
3.

Comment 1

11 years ago
Firefox has it set to 2 while SeaMonkey inherited the value of 0 from the old suite. Neil, Kairo, is there a reason for not setting it to 2 in SeaMonkey?
FYI, I just set it to zero in user.js; but I'm still curious. Neil, KaiRo (and maybe others), should this bug be Confirmed or WONTFIXed?
Version: unspecified → SeaMonkey 1.1 Branch
Personally I'm also in favor of changing our default to 2 in sync with FF.

Confirming in order to make it more likely to get an answer one way or another.

Neil, KaiRo: ping! Maybe take the discussion to m.d.a.seamonkey?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: bugday0420
Version: SeaMonkey 1.1 Branch → Trunk

Comment 4

9 years ago
So, this is, despite the hard-to-understand description, actually a bug for "open new tabs and not new windows by default"?

If so, I agree that we probably should do it now - if Neil agrees as our "UI tsar".
Assignee: general → nobody
Component: General → Tabbed Browser
QA Contact: general → tabbed-browser
(In reply to comment #4)
> So, this is, despite the hard-to-understand description, actually a bug for
> "open new tabs and not new windows by default"?
Apparently not, just a bug for "If want new tabs for links with target=_blank then don't divert window.open() with features into new tabs too."

Comment 6

9 years ago
I don't understand that description, and probably also don't understand the bug, then. This almost makes me think this is INCOMPLETE or INVALID for not describing the issue understandably for human beings.
(In reply to comment #6)
> I don't understand that description, and probably also don't understand the
> bug, then. This almost makes me think this is INCOMPLETE or INVALID for not
> describing the issue understandably for human beings.

I think the initial comment (which is a must-read in any bug if you ask me, and for me that goes without saying) is precise enough. When you look at the pref cited there you'll also understand how the bug got its summary. Whether the summary is appropriate may be up for discussion but this bug certainly contains enough information to understand what it's about so neither INCO nor INV apply. Maybe the summary needs tweaking, but that's about it. I feel that at least the reporter, Neil and me understand what the issue is. One of us can certainly try to explain it in other words again if need be.
(Reporter)

Comment 8

9 years ago
Hello.

My apologies for not describing the issue in a more descriptive manner. Perhaps
an example may be more appropriate?

For Example,

With the browser.link.open_newwindow.restriction configuration set to 0 , if
you go to a site such as
bestbuy.com and click on the weekly ad, you will notice the window open in a
new tab. This should not happen. Instead a window should popup with its unique
size.

If you change the browser.link.open_newwindow.restriction setting to 2, and
click on weekly ad again, you will notice the difference.

Please let me know if I  may be of any more assistance.
(Reporter)

Comment 9

9 years ago
this being that the open links meant to open in a new window is set to 

A new tab in the current window in Tabbed Browsing Preferences

Comment 10

9 years ago
I obviously didn't understand the pref, but I actually do feel that not opening new windows is good when someone has selected he wants tabs instead of new windows.

Still, I'll leave the decision to Neil.
(Reporter)

Comment 11

9 years ago
Setting to 2, still gives you the ability to open links in new tabs, just there may be an occasion where a site will want you to use a particular browser window size so that it looks normal.
Fixed through bug 505311.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.