If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmarks menu slow since icon landing

VERIFIED WORKSFORME

Status

SeaMonkey
Bookmarks & History
P3
minor
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Fredrik Sundberg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({perf})

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win98; I)
BuildID:    2000050111

The bookmarks menu has become painfully slow since the bookmark&folder icon 
landing a couple of days ago.

Reproducible: Always
Steps to Reproduce:
1. Just choose 'Bookmarks' and mouse over the bookmarks folders and bookmarks


Actual Results:  * Folder icon change (open/close) is lagging. [when mousing 
over folders]

* Bookmark highlighting is lagging even more   

Expected Results:  There should be no noticeable lagging when mousing in the 
bookmark menu.

My system:
PII 233MHz
64 Mb RAM

Comment 1

18 years ago
Confirming because this gives the appearance of a performance problem.

Using the same build on a K6-300 with 128MB running WinNT, there is no
lag at all highlighting folders and items on the Bookmarks menu, but the lag
showing the open folder icon is noticable -- at least 1/2 second from moving 
the pointer over the folder.

There is an inevitable delay in showing submenus -- otherwise running the
pointer down the menu to go to a submenu near the bottom would open every
submenu in turn on the way -- but the open folder icon is lagging after that,
which makes the process of moving into a submenu look slower than it is. 
The eye is drawn back to the left just as the eye-hand system is about to
move the pointer right. To make matters worse, the previous folder item
changes back to a closed icon last of all.

Ideally, if there is no actual performance problem displaying and redisplaying
these icons, as the pointer enters a new folder on the main menu or a submenu,
the highlight would appear instantaneously, the icon would change to the open 
folder icon *immediately* after (~10 ms), and then, after the normal delay,
the submenu would appear if the pointer had not moved on (if it had, the
open folder icon would need to revert). That would make the interface
look snappy, ready to leap into action.

If that isn't possible to guarantee on slower machines, both folder icons
should still change *before* the submenu is displayed, with the previous one
closing before the new one opens, to make sure that the eye isn't drawn away 
from the submenu just as it is displayed.

Not sure -- this may be just a matter of reordering a few lines of code,
or if the XPToolkit calls are less atomic, it could be more work than that.

Checking all this with the 2000-05-02-08-M16 nightly on a P90 with 64MB
of 5-year-old memory running WinNT, the folder icon lag is very apparent.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf

Comment 2

18 years ago
*** Bug 38030 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
spamming.. 38030 is apperantly NOT a dup.

Updated

18 years ago
Target Milestone: --- → M18

Comment 4

18 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21

Comment 5

17 years ago
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben

Comment 6

17 years ago
Is anyone still seeing this?

Comment 7

17 years ago
The lag is mostly gone now. If you move your mouse up ad down really fast over
the bookmark menu, though, the highlight can't keep up with your pointer. It
just _feels_ slow, but it doesn't really cause an actual practical performance
problem. That also may be more of a general menu thing than this bug...

Comment 8

17 years ago
nav triage team:

Minus!
Keywords: nsbeta1-

Comment 9

16 years ago
As far as version 0.9.3:

But bookmarks performance on clicking on the bookmarks menu is still slow with a 
400kB bookmark file. Netscape 4.7x is much more quicker.

Also clicking a second time on the bookmark menu it is still slow => not useable 
at all.

But it's the best mozilla release ever seen!
Not bad. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → Future
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.