Bookmark pointing to file://///test/test.html freezes Firefox

RESOLVED DUPLICATE of bug 98682

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 98682
11 years ago
11 years ago

People

(Reporter: Pavel Penaz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.1.4pre) Gecko/20070415 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.1.4pre) Gecko/20070415 Firefox/2.0.0.3

Clicking a bookmark pointing to file://///test/test.html freezes Firefox 2.0.0.3.
Minefield freezes only for a few seconds. It seems the five consecutive slashes are the culprit, when I leave only two slashes, the problem disappears.



Reproducible: Always

Steps to Reproduce:
1. Create a bookmark pointing to file://///test/test.html
2. Click on the bookmark
Actual Results:  
The browser becomes unresponsive.

Expected Results:  
The browser should show "URL does not exist" error message.

Comment 1

11 years ago
It's because you're trying to access a non-available Windows UNC share. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 98682
You need to log in before you can comment on or make changes to this bug.