Suiterunner: Change height of Location Bar Dropdown Window

VERIFIED FIXED in seamonkey2.0a1

Status

defect
--
minor
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: tobias, Assigned: stefanh)

Tracking

Trunk
seamonkey2.0a1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/2007042318 Mnenhy/0.7.4.10010 SeaMonkey/1.5a (Suiterunner)

In Suiterunner, the Dropdown-Window (History-List) is much less high than in SeaMonkey XPFE-Builds. Using WinXP with 1280x1024 Resolution and normal Fonts, there are about 10 1/2 visited Locations visible when I drop down the Location bar. 

The Dropdown-Window in XPFE-Builds is much higher, there are 16 Entries visible when I drop down the Location Bar. 

Would be nice to get the Location Bar dropdown resized in Suiterunner.
I guess we get the height from *stripe's global files.
I assume this is classic-only. We lost the 25em height that was in classic/global/autocomplete.css. On mac, there are also a bunch of other issues (wrong bg-color, autocomplete drop-down looks bad as well). I'm not sure that this is the right time to fix this - afaik there will be some changes to the aoutocomplete widget on suiterunner. I'm setting this one to block the "main" tracker for now - perhaps there should be a "theme issues in suiterunner" tracker instead.
Blocks: suiterunner
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Blocks: 382795
We can probably add this style to communicator.css so that the other places where there are autocomplete history popups will pick up the override.
Keywords: helpwanted
Whiteboard: [good first bug]
Posted patch Fix heightSplinter Review
So I have only tested this in navigator, due to some possible cocoa-issue I can't test the autocomplete stuff in editor (composer).
Assignee: guifeatures → stefanh
Status: NEW → ASSIGNED
Attachment #291874 - Flags: superreview?(neil)
Attachment #291874 - Flags: review?(neil)
Keywords: helpwanted
Whiteboard: [good first bug]
Target Milestone: --- → seamonkey2.0alpha
Attachment #291874 - Flags: superreview?(neil)
Attachment #291874 - Flags: superreview+
Attachment #291874 - Flags: review?(neil)
Attachment #291874 - Flags: review+
Checking in suite/themes/classic/communicator/communicator.css;
/cvsroot/mozilla/suite/themes/classic/communicator/communicator.css,v  <--  communicator.css
new revision: 1.23; previous revision: 1.22
done
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verfied=Fixed, thanks Stefan. 
Even if this one was a good first Bug, I am not able to submit a patch, to less programming knowledge. :(
Status: RESOLVED → VERIFIED
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.