If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

User cannot identify disabled form controls when page colors are overriden (high-contrast-mode).

RESOLVED DUPLICATE of bug 58048

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 58048
11 years ago
10 years ago

People

(Reporter: Tom Brunet, Unassigned)

Tracking

(Blocks: 1 bug, {access, sec508})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 (CK-IBM) Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 (CK-IBM) Firefox/2.0.0.3

When page colors are overriden, the rendering engine applies foreground and background color to the disabled control, and throws out color blending done to indicate disabled controls.

Reproducible: Always

Steps to Reproduce:
1. Override page colors (Tools->Options->Content->Color).  Check "Use System Colors" and uncheck "Allow pages to choose their own colors".
2. Load the attached "disabled.html" or load any page that has disabled form controls.

Actual Results:  
The left set of controls in the "disabled.html" are active controls and the right set are disabled controls.  Notice that the radio button and checkbox maintain their disabled colorings, however the button and text box are difficult or impossible to identify which is the disabled form control.
(Reporter)

Comment 1

11 years ago
Created attachment 262766 [details]
Pairing of some active and disabled form controls
(Reporter)

Updated

11 years ago
Blocks: 343205

Comment 2

11 years ago
Is it a problem for XUL as well?
Assignee: aaronleventhal → nobody
Component: Disability Access APIs → Layout: Form Controls
Keywords: access, sec508
QA Contact: accessibility-apis → layout.form-controls
(Reporter)

Comment 3

11 years ago
No, Aaron.  It appears not to affect the XUL equivalent controls.  I'll attach an XUL equivalent to the HTML version.
(Reporter)

Comment 4

11 years ago
Created attachment 264007 [details]
XUL version of the HTML controls in the previous attachment.

This is an XUL version of the HTML controls in attachment 262766 [details].
Fixed on trunk a while ago.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 58048
You need to log in before you can comment on or make changes to this bug.