Quick Search plugin does not conform to OpenSearch specification

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Query/Bug List
--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Zak Johnson, Assigned: Zak Johnson)

Tracking

Bugzilla 3.0
Bug Flags:
approval +
approval3.0 +

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 3.0rc1

The Quick Search plugin does not work in my copy of IE7 (7.0.5730.11).  This seems to be because search_plugin.cgi does not emit a valid OpenSearch file.  According to the spec at http://www.opensearch.org/Specifications/OpenSearch/1.1, neither the <Param> nor the <SearchForm> elements exist.

Reproducible: Always

Steps to Reproduce:
1. Install Quick Search plugin in IE.
2. Make a search.
Actual Results:  
Location bar shows buglist.cgi with no parameters.  Bugzilla generates an error: "You may not search, or create saved searches, without any search terms."
(Assignee)

Comment 1

11 years ago
Created attachment 262778 [details] [diff] [review]
Fix for v3.0 branch

This patch conforms to the OpenSearch spec and works for me in both FF 2.0.0.3 and IE7.
Indeed, IE7 does emit such an error.
Assignee: query-and-buglist → zakj
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Bugzilla 3.0
Version: unspecified → 3.0
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

11 years ago
Attachment #262778 - Flags: review?
Comment on attachment 262778 [details] [diff] [review]
Fix for v3.0 branch

Looks like a correct change according to the Draft 3 of the OpenSearch 1.1 specification. I tested this to work with both IE7 and FF2. Those are the only browsers that support this plugin per page http://www.opensearch.org/Community/OpenSearch_search_clients so this change should be fine.

Note that this patch doesn't apply to trunk due to changes done by bug 369933.

Also note that one needs to remove and add the search plugin again to get a working version.
Attachment #262778 - Attachment description: fix → Fix for v3.0 branch
Attachment #262778 - Flags: review+
Attachment #262778 - Flags: review?
Created attachment 262783 [details] [diff] [review]
Fix for trunk
Attachment #262783 - Flags: review+
Thanks for the patch!
Flags: approval?
Flags: approval3.0?

Comment 6

11 years ago
Just on time for 3.0.
Flags: approval?
Flags: approval3.0?
Flags: approval3.0+
Flags: approval+
OS: Windows XP → All
Hardware: PC → All

Comment 7

11 years ago
Comment on attachment 262778 [details] [diff] [review]
Fix for v3.0 branch

Shouldn't this be using correct_urlbase??
> (From update of attachment 262778 [details] [diff] [review])
> Shouldn't this be using correct_urlbase??

Probably, but like you can see it wasn't using before so that's not part of this bug. Feel free to backport the patch in bug 369933 if you want that fixed on the 3.0 branch too.

Comment 9

11 years ago
(In reply to comment #7)
> Shouldn't this be using correct_urlbase??

Not required as we didn't commit bug 369933 on the 3.0 branch.

Comment 10

11 years ago
tip:

Checking in template/en/default/search/search-plugin.xml.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/search/search-plugin.xml.tmpl,v  <--  search-plugin.xml.tmpl
new revision: 1.3; previous revision: 1.2
done

3.0 RC1:

Checking in template/en/default/search/search-plugin.xml.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/search/search-plugin.xml.tmpl,v  <--  search-plugin.xml.tmpl
new revision: 1.1.2.1; previous revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.