messenger sends out wrong data for charset

VERIFIED WORKSFORME

Status

MailNews Core
Internationalization
P1
normal
VERIFIED WORKSFORME
19 years ago
9 years ago

People

(Reporter: John G. Myers, Assigned: rhp (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DEPEMD - Intl)

(Reporter)

Description

19 years ago
(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #333114
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=333114
Imported into Bugzilla on 03/15/99 19:16)

Click on "new message"
Select "View/Character set/UTF-8"
Address the message
In the body, add a division sign by holding down ALT and typing 246 on the
numeric keypad.
Send the message.

The message sent out is as follows. =F7 is not legal UTF-8, it is the ISO-8859-1
encoding for the division sign.

Message-ID: <363FB108.86AF92F3@netscape.com>
Date: Tue, 03 Nov 1998 17:42:32 -0800
From: John Gardiner Myers <jgmyers@netscape.com>
X-Mailer: Mozilla 4.5 [en] (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
To: John Myers <jgmyers@netscape.com>
Subject: test
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

this is a test=F7

Comment 1

19 years ago
-> jefft, cc bobj,nhotta,lchiang

Comment 2

19 years ago
Not a regression from 4.51, in 4.5 - WONTFIX
(Reporter)

Comment 3

19 years ago
At the very least, this needs to be fixed in 5.0

Updated

19 years ago
Assignee: marek → jefft
Status: REOPENED → NEW
QA Contact: 1308

Comment 4

19 years ago
reassign to jefft@netscape.com (who the bugsplat bug was assigned to)

Updated

19 years ago
Target Milestone: M4

Comment 5

19 years ago
This was not a problem in HTML mail -- restricted to plain text.
Should be reviewed when the Sending mail becomes functional in 5.0
for both plain and HTML mail.
Tenatively set for M4 for review and further disposition.

Updated

19 years ago
Assignee: jefft → ducarroz

Comment 6

19 years ago
Reassigning to Jean-Francois who works on mail compose for mail5.

Updated

19 years ago
Target Milestone: M4 → M6

Comment 7

19 years ago
M6

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: ducarroz → rhp
Status: ASSIGNED → NEW
reaasign ro Rich Pizzaro has he now own the backend part of message composition
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M6 → M7

Updated

18 years ago
Whiteboard: DEPEMD - Intl

Updated

18 years ago
Blocks: 7228
(Assignee)

Updated

18 years ago
Target Milestone: M7 → M8
(Assignee)

Comment 9

18 years ago
Legacy bug...moving to M8.
(Assignee)

Updated

18 years ago
Target Milestone: M8 → M9
(Assignee)

Comment 10

18 years ago
Bump to M9 and will verify when I can run again.

- rhp
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 11

18 years ago
I just tested this with SeaMonkey and it looks like we've fixed this in
5.0...how about that :-)

- rhp

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 12

18 years ago
verified worksforme
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.