Images should be interpolated when resized

RESOLVED DUPLICATE of bug 98971

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 98971
11 years ago
11 years ago

People

(Reporter: keenanpepper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)

When a large image is resized to fit within the window, or an image is resized with the "height" or "width" HTML attributes, it often has aliasing artifacts like "jaggies" or moiré. Firefox should use a better scaling algorithm to avoid this.

I thought this bug must have been reported already, but I searched for "interpolation", "aliasing", "artifact", and other keywords and couldn't find anything. Sorry if it's a duplicate.

Reproducible: Always
You probably weren't searching for closed bugs, then, or you would probably have found the fixed (on the trunk, for Fx 3) one and its net of duplicates.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 98971
You need to log in before you can comment on or make changes to this bug.