"Empty Trash" scrolls the folder tree display/view one row up, when at its bottom

NEW
Unassigned

Status

SeaMonkey
MailNews: Message Display
--
minor
11 years ago
5 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Steps: comment 7] [2012 Fall Equinox])

(Reporter)

Description

11 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.12pre) Gecko/20070322 SeaMonkey/1.0.8] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.4pre) Gecko/20070421 SeaMonkey/1.1.1] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a4pre) Gecko/20070426 SeaMonkey/1.5a] (nightly) (W2Ksp4)

Often, when I use "Empty Trash", the left tree view on the 3-pane window moves one row up:
previous row is added at the top of the view;
last displayed row is removed at the bottom.

It seems not to be always reproducible,
but, when it happens, I think it happens only on the first use after starting MailNews.

Comment 1

11 years ago
You mean one of your folders/newsgroups then moved to the top?!
(Reporter)

Comment 2

11 years ago
No, the order of the items are unchanged:
it's only as if I had clicked once on the up arrow of the lift.
(Reporter)

Comment 3

11 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.13) Gecko/20060414] (release) (W2Ksp4)

Bug was already there too.

Comment 4

10 years ago
Can you reproduce with SeaMonkey 1.1.9 ?
(Reporter)

Comment 5

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1] (release) (W2Ksp4)

Can't reproduce :-/

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070515 SeaMonkey/1.5a] (nightly) (W2Ksp4)

Haven't seem this for a long time.

***

R.WorksForMe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> [Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070515
> SeaMonkey/1.5a] (nightly) (W2Ksp4)
> 
> Haven't seem this for a long time.

Well ... I could "reproduce" twice since then.
I'll try and find some reproducible steps...

ReOpening.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Summary: "Empty Trash" moves the tree display/view one row up → "Empty Trash" scrolls the folder tree display/view one row up
(Reporter)

Comment 7

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070515 SeaMonkey/1.5a] (nightly) (W2Ksp4)

It would seem I can reproduce all the time:
*Trash folder does not need to be currently selected.
*Folder tree must be longer than its view,
 and the view must be set at its bottom (= seeing last folder).
Summary: "Empty Trash" scrolls the folder tree display/view one row up → "Empty Trash" scrolls the folder tree display/view one row up, when at its bottom
(Reporter)

Comment 8

10 years ago
(In reply to comment #5)
> [Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.2) Gecko/20070222
> SeaMonkey/1.1.1] (release) (W2Ksp4)
> 
> Can't reproduce :-/

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9] (release) (W2Ksp4)

Easier to reproduce, now that I have figured out the triggering case.

***

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008060601 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

Bug with the v2.0a1 trunk too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Steps: comment 7]
Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1 ID:20120921003032 c-c:dbd153b0fa9c m-c:9ae014a115b2

Tried and couldn't. However:
- I have NNTP newsgroups below mail servers in the Folders pane. When a newsgroup is selected, there is no "File → Empty Trash" menuitem.
- My (Local Folders) trash folder is currently empty.
- I'm on Linux.
Whiteboard: [Steps: comment 7] → [Steps: comment 7] [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.