Closed Bug 379043 Opened 14 years ago Closed 14 years ago

CSS background images aren't displayed for file input elements

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 52500

People

(Reporter: greenie2600, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

The CSS property background-image is ignored for <input type="file">.


Reproducible: Always

Steps to Reproduce:
Insert the following HTML code in any HTML document, and view it in Firefox:

<input type="file" style="background-image: url('http://www.mozilla.com/img/template/moz-com-logo.png');" />


Actual Results:  
No background image was displayed.

Expected Results:  
I expected a background image to be applied to the interior of the text box.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: input[type=file]
You need to log in before you can comment on or make changes to this bug.