Make dashed/dotted border rendering pretty again

RESOLVED FIXED

Status

()

Core
Layout
P5
normal
RESOLVED FIXED
10 years ago
a year ago

People

(Reporter: vlad, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Dependency tree / graph
Bug Flags:
wanted-next +
blocking1.9 -
wanted1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dbaron-1.9:RwCo])

Attachments

(3 attachments)

As part of the landing of bug 368247 dashed and dotted borders aren't as pretty as they used to be, especially at thick border widths in a small space.  This should be fixed; it should not be an especially complicated fix, just some extra logic in creating the paths.
Created attachment 263292 [details]
example showing old and post-patch dashed rendering

example.
The stuff in bug 19963 should be considered when fixing this, if possible.
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
Whiteboard: [dbaron-1.9:RwCo]
Priority: -- → P5
Keywords: regression

Comment 3

10 years ago
Created attachment 303033 [details]
bg image used in the next attachment

Comment 4

10 years ago
Created attachment 303034 [details]
In FF3 the top border of an element is rendered with a smaller height if the DIV is empty and border-top-style is not (dotted or dashed) and border-bottom-style is (dotted or dashed) and border-top-width is greater than border-bottom-width

In FF3 the top border of an element is rendered with a smaller height if:

* the DIV is empty and
* border-top-style is not (dotted or dashed) and 
border-bottom-style is (dotted or dashed) and * border-top-width is greater than border-bottom-width

Updated

10 years ago
Attachment #303034 - Attachment description: if → In FF3 the top border of an element is rendered with a smaller height if the DIV is empty and border-top-style is not (dotted or dashed) and border-bottom-style is (dotted or dashed) and border-top-width is greater than border-bottom-width
The previous comment was filed as bug 417246, which should block.

I think this one shouldn't block, although I'll leave it wanted.
Flags: wanted1.9+
Flags: blocking1.9-

Updated

9 years ago
Flags: tracking1.9+
Flags: wanted1.9-
Flags: wanted1.9+
Flags: wanted-next+

Updated

9 years ago
Depends on: 446498

Comment 6

9 years ago
This is essentially the same bug as https://bugzilla.mozilla.org/show_bug.cgi?id=19963.
That bug has the highest priority of all dotted-border-corners-ugly related bugs. It is also the oldest and it has a (seemingly active) developer assigned to it.
I suggest to "merge" this bug with 19963. If you care, please check it out and vote for it.
It's not quite the same bug.  Fixing that bug might fix this one, but this one can be fixed without fixing the other, really, since this one is a recent regression and the other clearly is not.
Depends on: 19963
IMO it doesn't make sense to do anything but fix the entire problem at one go.  I hope to get back to bug 19963 this week.
Assignee: vladimir → nobody

Updated

2 years ago
Depends on: 382721
Fixed as a part of bug 382721.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.