If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<hr> drawn incorrectly, often diagonally

VERIFIED FIXED

Status

()

Core
Layout
--
major
VERIFIED FIXED
11 years ago
5 years ago

People

(Reporter: Radek 'sysKin' Czyz, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070501 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070501 Minefield/3.0a5pre

Starting with today's nightly, <hr> is drawn incorrectly at that page. If window is not wide enough, <hr> is too long and consists of several lines at different angles. As window gets wider, all lines become more and more horizontal, until they form proper <hr>

Reproducible: Always

Steps to Reproduce:
1. Go to http://forums.whirlpool.net.au/forum-user.cfm?id=82054
2. Observe horizontal line under "Recent thread participation"
3. Make window narrower and wider to see the cool effect ;)
Actual Results:  
Not all lines forming <hr> are horizontal


Apparently also confirmed on Linux x64 and xpfe seamonkey.

Worked fine in 20070430 build.
Regression from bug 368247.
Blocks: 368247
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
Created attachment 263450 [details]
Testcase from pal-moz

Comment 3

11 years ago
(In reply to comment #2)
> Created an attachment (id=263450) [details]
> Testcase from pal-moz
> 

detail testcase, with prob and with no prob.
http://forums.mozillazine.org/viewtopic.php?p=2865572#2865572

Updated

11 years ago
Keywords: regression, testcase
Duplicate of this bug: 379497
Flags: in-testsuite?

Comment 5

11 years ago
bug also present on this site:
http://www.nzone.com/object/nzone_downloads_rel70betadriver.html

Flags: blocking1.9?

Updated

11 years ago
Summary: <hr> drawn incorrectly → <hr> drawn incorrectly, often diagonally
I have a fix for this, but it's tied up with a fix for another related bug that I'm still having problems with.  Should be in by the end of the day though.

Comment 7

11 years ago
Appears on http://lotti.altervista.org/wwtbafm/ and it's even antialiased!
Duplicate of this bug: 379964
Fixed by patch checked in for bug 379474.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: blocking1.9?

Comment 10

11 years ago
Verified fixed on Minefield/3.0a5pre ID:2007051004 [cairo]
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.