Mysterious comma in decompilation of sharp declaration

VERIFIED FIXED

Status

()

Core
JavaScript Engine
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
x86
Mac OS X
testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
js> function () { return #1=[a]; }   
function () {
    return #1=[, a];
}

js> function () { return #1={a:b}; } 
function () {
    return #1={, a:b};
}

The first is incorrect, since it changes the size of the array.  The second doesn't even compile.
(Reporter)

Updated

11 years ago
No longer blocks: 349611
(Reporter)

Updated

11 years ago
Blocks: 349611

Comment 1

10 years ago
This appears to have been fixed in the interim.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Flags: in-testsuite?
I fixed this as part of bug 376957 but apparently forgot to mark the fix as such.  (Dangit, I still need to write that let-expression fix for the remaining regression from that, don't I?)
Depends on: 376957
Resolution: WORKSFORME → FIXED

Comment 3

10 years ago
/cvsroot/mozilla/js/tests/js1_5/extensions/regress-379523.js,v  <--  regress-379523.js
initial revision: 1.1
Flags: in-testsuite? → in-testsuite+

Comment 4

10 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.