Script Error Dialog contains too long string and makes it uncloseable

RESOLVED DUPLICATE of bug 378837

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 378837
11 years ago
11 years ago

People

(Reporter: Sean Lynch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11

After browsing to the indicated URL, a dialog with the following code was displayed:

http://www.10best.com

Error loading script
[http://....ridiculously long url...
- line 1]

The URL was so big, that it stretched the dialog box to its maximum width. The string continued past this maximum.  It appeared that the "Okay" button was also placed beyond this maximum position and thus the user is not able to close the dialog box. 


Reproducible: Couldn't Reproduce

Comment 1

11 years ago
I see this on trunk with:

javascript:x = "x"; for(i=0;i<11;++i) x+=x; alert(x);

Sounds like the same problem as bug 378837.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378837
You need to log in before you can comment on or make changes to this bug.