Closed Bug 379688 Opened 14 years ago Closed 14 years ago

Startup screen "Download Addon update" does not succeed no proxy used

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 312473

People

(Reporter: bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

The Firefox application is separated from the web with a normal socks proxy. 
At a normal start-up the proxy user-ID and password are requested before any information beyond the proxy can be retrieved.
If Firefox found an update for an Add-on during it's last session, then it will ask at start-up if you wish to install the update. This happens before the proxy user-ID and password have been requested, and is therefore unable to download the update for installation. The user must then wait until firefox has completed its startup and manually enter the Extras->Add-ons menu and check for updates.

Reproducible: Always

Steps to Reproduce:
1. Ensure that proxy requests user-ID and password at every startup.
2. Install old version of Adblock plus
3. Restart firefox
Actual Results:  
See details description

Expected Results:  
The proxy information should be requested when the user clicks on the "install update" button in the startup upgrade manager window.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312473
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.