Last Comment Bug 379722 - Starting Firefox or Thunderbird 2.0.0.4 prints "Handling command line!"
: Starting Firefox or Thunderbird 2.0.0.4 prints "Handling command line!"
Status: RESOLVED FIXED
: regression, verified1.8.1.4
Product: Toolkit
Classification: Components
Component: Startup and Profile System (show other bugs)
: 1.8 Branch
: x86 Linux
: -- minor (vote)
: ---
Assigned To: Benjamin Smedberg [:bsmedberg]
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
http://lxr.mozilla.org/mozilla1.8/sou...
Depends on:
Blocks: 375710
  Show dependency treegraph
 
Reported: 2007-05-04 09:01 PDT by Frédéric Buclin
Modified: 2008-07-31 03:03 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove the dump() line (609 bytes, patch)
2007-05-07 08:25 PDT, Nick Thomas [:nthomas]
benjamin: review+
dveditz: approval1.8.1.4+
Details | Diff | Splinter Review

Description Frédéric Buclin 2007-05-04 09:01:09 PDT
That's a "regression" due to bsmedberg's fix in bug 375710. The debug message has not been removed on checkin.
Comment 1 Daniel Veditz [:dveditz] 2007-05-04 19:16:22 PDT
I was going to point at bug 375710 comment 100 saying it should only show up for people who explicitly turn on a debugging pref, but it turns out the debugging pref only affects dump() used in a DOM context (window.dump()). JS components dump() is enabled all the time and this really should be removed.

We should also file a bug to "fix" dump() in JS components to prevent this confusion in the future, one of
 - make it obey the pref
 - make it debug-build-only if pref too hard
 - rename it to avoid confusion over behavior differences (print?)
Comment 2 Daniel Veditz [:dveditz] 2007-05-04 19:50:44 PDT
Filed bug 379797 on the dump() confusion.
Comment 3 Nick Thomas [:nthomas] 2007-05-07 08:25:43 PDT
Created attachment 264010 [details] [diff] [review]
Remove the dump() line

Seeking review, should we want to take this patch for a respin of the release.
Comment 4 Benjamin Smedberg [:bsmedberg] 2007-05-07 08:28:37 PDT
Comment on attachment 264010 [details] [diff] [review]
Remove the dump() line

We'll need to land this on MOZILLA_1_8_BRANCH as well as the release branch.
Comment 5 Daniel Veditz [:dveditz] 2007-05-07 10:28:02 PDT
Comment on attachment 264010 [details] [diff] [review]
Remove the dump() line

approved for 1.8.1.4, a=dveditz for release-drivers

Could also use debug() instead of dump() if you want to leave these in in the future.
Comment 6 Nick Thomas [:nthomas] 2007-05-07 10:32:53 PDT
Checked in on MOZILLA_1_8_BRANCH:

Checking in nsDefaultCLH.js;
/cvsroot/mozilla/toolkit/components/nsDefaultCLH.js,v  <--  nsDefaultCLH.js
new revision: 1.5.8.4; previous revision: 1.5.8.3
done
Comment 7 Frédéric Buclin 2007-06-05 11:12:45 PDT
Fixed in version 2.0.0.5pre (20070604)

Note You need to log in before you can comment on or make changes to this bug.