document.designMode does not support rich text or HTML pasteboards from other apps.

RESOLVED DUPLICATE of bug 79864

Status

()

RESOLVED DUPLICATE of bug 79864
12 years ago
12 years ago

People

(Reporter: james, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

document.designMode does not support rich text or HTML pasteboards from other apps.

An easy test is to copy rich text from another app like Safari or Word, then try to paste it into the test case. It pastes as plain text. Copying in Firefox then pasting works fine.


Reproducible: Always

Steps to Reproduce:
1. copy rich text from another app
2. paste it into designMode page

Actual Results:  
pastes as plain text.

Expected Results:  
paste as rich text or html text
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 79864
You need to log in before you can comment on or make changes to this bug.