Positioned div with padding makes link in other positioned div below it not work

RESOLVED DUPLICATE of bug 102695

Status

()

RESOLVED DUPLICATE of bug 102695
12 years ago
12 years ago

People

(Reporter: timonchristl, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Created attachment 264042 [details]
Test case

I have two divs, one with position:absolute, and one with position:relative and padding-top:20px. In the first div there is a link. This link does not work, there are no hovering effects (no hand cursor) and it cannot be clicked. It seems to receive no mouse events at all. If I remove one of the position style rules, the link works again.

It seems that the padding area of the second div is not transparent to events in this particular situation.

In IE7 and Opera 9.2 this works as I would expect, the link can be clicked.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Attaching a simple test case.
Bug 102695 ?
Please don't file layout bugs as NEW in Firefox::General.
Component: General → General
Product: Firefox → Core
QA Contact: general → general

Updated

12 years ago
Keywords: testcase
Version: unspecified → Trunk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 102695
You need to log in before you can comment on or make changes to this bug.