plaintext equivalent of – in mail clips visible mail wrong?



MailNews Core
18 years ago
10 years ago


(Reporter: R.K.Aa., Assigned: rhp (gone))


Firefox Tracking Flags

(Not tracked)



(2 attachments)



18 years ago
M16 linux 2000-050215
I'm not 100% sure what happens here. Summary and module may be wrong.
Attachment follows.

The problem-mail in this case is truncated on left side: the 7 first characters
on each line are not visible.

The mail had two formats in one - both plain text (truncated) and a html-version
(which didn't display at all, probably my own preference).

I'm guessing that the clipping error is caused by the plain-text character that
in html would be –
This because there also were problems copying from source - got truncated as
well. (Submitting a separate bug on that)

(NC4.7 seems to translate &#8211 to ASCII 45 by the way.)

Comment 1

18 years ago
Created attachment 8241 [details]
full source of troubled mail (.txt)

Comment 2

18 years ago
cc: rhp.
QA Contact: lchiang → pmock

Comment 3

18 years ago
filed bug 38016 about how – and ” breaks copying 

Comment 4

18 years ago
I think you are talkinga bout the display of the message body right? I think
this goes to rhp. What do you think Rich?
Assignee: mscott → rhp

Comment 5

18 years ago
Probably...plain text display has been regressing pretty badly. :-(

- rhp

Comment 6

18 years ago
Created attachment 8261 [details]
line starting w. 14.05 is really: 12.05 - 14.05


18 years ago
Target Milestone: --- → M18

Comment 7

18 years ago
Cleanup to M18.


18 years ago


18 years ago
Keywords: correctness, nsbeta3

Comment 8

18 years ago
I have a feeling that this bug is invalid. I took the original message and 
tried rendering this in Seamonkey, Internet Explorer and Outlook Express and 
they all rendered exactly the same way (i.e. truncated on the left).

- rhp
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 9

18 years ago
That's odd. Double-checked it right now:  Downloaded the attachment, pasted it
into NC 4.72's Inbox (adding two linefeeds) - the mail as seen with NC4.72 looks
like it should - it is not at all truncated.

Seamonkey truncating it is no wonder - that is what this bug-report is all
about. Did you check how it looks in Netscape 4.* ? Which versions of MSIE and
Outlook did you check? Since the mail was actually originally sendt via Outlook,
that is of some interest. I can find out which version was used also.

Comment 10

18 years ago
umm the mailer version is actually in the header of attachment - a build id.
But i can't say i look forward to having to read mails from work with "view

Comment 11

18 years ago
What I'm saying is that I believe the HTML is being rendered as it is coded 
when it is truncated on the left. 4.7 is not as standards compliant as 
Seamonkey and the latest versions of IE so you can't use 4.x behavior of how 
it "should" appear. I tested against IE 5.5 and OE 5.0 and both truncated on 
the left.

- rhp

Comment 12

18 years ago
Verified as invalid on win32, linux, and macos using the following builds:

 win32 commercial seamonkey build 2000-102509-mn6 installed on P500 Win98
 linux commercial seamonkey build 2000-102509-mn6 installed on P200 RedHat 6.2
 macos commercial seamonkey build 2000-102508-mn6 installed on G3/400 OS 9.04
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.