add-ons/extensions update fail to auth the proxy at startup

RESOLVED DUPLICATE of bug 312473

Status

()

RESOLVED DUPLICATE of bug 312473
11 years ago
10 years ago

People

(Reporter: higuita, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070310 Iceweasel/2.0.0.3 (Debian-2.0.0.3-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070310 Iceweasel/2.0.0.3 (Debian-2.0.0.3-1)

hi

i started the firefox with "recover last sessions" (i killed firefox) and it found  some add-ons/extensions updates...
when i try to update then, it fails, checking the squid logs i get:

1178783113.628      8 10.10.20.157 TCP_DENIED/407 2071 GET http://releases.mozilla.org/pub/mozilla.org/addons/3155/corrector_para_portugue
s_europeu-7.4.27.0-fx+tb+sm.xpi - NONE/- text/html
1178783118.531      2 10.10.20.157 TCP_DENIED/407 1984 GET http://releases.mozilla.org/pub/mozilla.org/addons/433/flashblock-1.5.3-fx+fl.x
pi - NONE/- text/html

please note the 407 error, "proxy authentication required"

if i cancel it and let the firefox to finish the startup, i then go the the add-ons and update the packages without any problem.

i would say that the update in the startup doesnt call the same functions as the  one in the add-ons menu.

Reproducible: Always

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312473

Comment 2

11 years ago
I have the same problem. The point is that the Firefox pre-boot update screen doesn't present a screen to type login data. Therefore it tries to go through the proxy without authenticating, which fails, ofcourse.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.