Mail filters "Add Star" and "Tag" don't work on incoming messages

REOPENED
Unassigned

Status

MailNews Core
Filters
REOPENED
11 years ago
8 years ago

People

(Reporter: Stephan Golux, Unassigned)

Tracking

(Blocks: 1 bug)

1.8 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs protocol log])

(Reporter)

Description

11 years ago
NB:  This bug seems to have been introduced between 1.8 and 2.0.

Using Thunderbird version 2.0.0.0 (20070326)

I have a filter based on a custom mail header.

    CONDITION:
        X-Spam-Level Contains *

    ACTION:
        Add Star

(I believe in version 1.8, this was "Add Flag")

On incoming messages, the star is simply not added to messages which meet the criteria.  If I subsequently "Run Filters On Folder", the star is added as expected.  If I change the action to move the message to a folder, that is done as expected on incoming messages.  If I change the action to move the message to a folder AND at the star, the incoming message is ONLY moved to the folder, but the star is not applied.

The same problem seems to exist if you try to TAG an incoming message.  Again, when the message is being received, the filter just won't work, but if you run it by "Run Filters on Folder", then it will work.

Filter log indicates to me (if I am reading it correctly) that the filter ran successfully, but in fact it did not.

Comment 1

11 years ago
This is fixed in the nightlies.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355537
(Reporter)

Comment 2

10 years ago
At the email suggestion of Wayne Mery (vseerror@Lehigh.EDU) I am re-opening this bug because it appears it should not have been marked as a duplicate on 5/15.

I am still seeing the exact same behavior as in my original post, except now I am running 2.0.0.6 of Thunderbird.

I have always updated Thunderbird when invited to do so by the automatic update program, but this has been and has remained broken since version 1.8.

Wayne suggested I also add that this bug had been "filed" because the supposed duplicate 355537 was closed, but that this seems to have been a simple mistake.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

10 years ago
stephan, do you mean version 1.8 of mozilla (suite)?
(Reporter)

Comment 4

10 years ago
You are stretching my memory, but I think it was version 1.8 of Thunderbird.  Does that sound silly?  However, I am now running 2.0.0.9 of Thunderbird, and it may be that the bug is now fixed.  I will run a couple of tests to see if this is true.  Stay tuned.  It was definately still broken in 2.0.0.6.
(Reporter)

Comment 5

10 years ago
I understand that there was no 1.8 of Thunderbird, so I am not sure what to make of my initial bug report.

However, the bug still exists for me.  If an incoming mail meets filter requirements for which the action is ONLY "Add Star" it will not happen.

If, after the mail has arrived, you "run filters on folder", the star will be added.

If, instead, you change the filter so that the action is to move the message in question to a different folder, that works fine.

This is as of Thunderbird version 2.0.0.9.

I do distinctly believe that I was running a version of Thunderbird in the old days where these did work.

Please let me know if there is any further testing you would like me to do on my setup.
Blocks: 432710

Updated

9 years ago
Assignee: mscott → nobody
Status: REOPENED → NEW

Comment 6

8 years ago
works fine for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3pre) Gecko/20090809 Shredder/3.0b4pre

can you reproduce with version 2 and version 3 beta 3?
 http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
 (backup your profile before using - note, it marks all folders for offline use)
Component: Mail Window Front End → Filters
Product: Thunderbird → MailNews Core
QA Contact: front-end → filters
Version: 2.0 → 1.8 Branch
(Reporter)

Comment 7

8 years ago
I am moving and can't test the beta at the moment - but this has been working fine for me for several months at least.  Currently also working fine on version 2.0.0.22 (20090605) of Thunderbird, what I am currently using.  Thanks.

Comment 8

8 years ago
->WFM then
Status: NEW → RESOLVED
Last Resolved: 11 years ago8 years ago
Resolution: --- → WORKSFORME

Comment 9

8 years ago
This bug is still not fixed.

I am also running Version 2.0.0.22(20090605) under Vista Business Edition
(en-UK) and the bug is still present.  

I have the 1st line of the filter set to mark messages with a star and the
second to move it to another folder.  The message is moved, but no star is
added.

Comment 10

8 years ago
Patrick: please try beta3 and report back
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/

Comment 11

8 years ago
I have now installed 3.0 beta 3.  All existing e-mails were given stars.  However, the one received since installation has been transferred to the relevant folder but has not had the star added.

Updated

8 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 12

8 years ago
Patrick, I need more details. There are many variations of this, all with different possible causes and fixes.

1. Does this behavior only happen when add star is combined with a move?
2. Do you get the same behavior with a copy?
3. What kind of server are you moving from, and what kind are you moving to? Are they the same or different servers?

Comment 13

8 years ago
The moves are within the same server (Apache server with Plesk management).
I'll set up some filters to copy, add star and move etc and report back in a day or so.

Comment 14

8 years ago
An imap protocol log of a session where this happens might be helpful here - https://wiki.mozilla.org/MailNews:Logging

One possibility is that your imap server isn't maintaining the /Flagged flag when copying messages between folders.

Comment 15

8 years ago
I don't believe it to be a server problem since the messages are only being moved from the inbox to a sub-folder on the same PC and, as I have now discovered, the results vary between PCs.

I have now installed 3.0 Beta 3 on my desktop (Windows Vista Business partition) and a Linux partition (OpenSUSE 11.1), and on my laptop (Windows Vista Home Premium).

The results are strange.  

On the Linux partition no star is added at all, even if not combined with a move. 

On the Vista Business partition the star is added if no move is involved but not if a move/copy is involved (unless the filter is run manually).

On the laptop the filter appears to work properly.

These results apply to identical filters, filtering the same messages on each machine.

Comment 16

8 years ago
even if it's not a server problem, a protocol log may be helpful
Whiteboard: [needs protocol log]
You need to log in before you can comment on or make changes to this bug.