FF crashes sometimes when FF is closed [@ nsCaretAccessible::NotifySelectionChanged]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: mkreft, Unassigned)

Tracking

({crash})

2.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

When I want to close FF it sometimes crashes


Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Talkbalk agent starts

Expected Results:  
FF should be closed smoothly

TB32033049G

firefox.exe, Version 1.8.20070.30919, Modul firefox.exe, Version 1.8.20070.30919, Address 0x0043ba02
(Reporter)

Updated

12 years ago
Keywords: crash
Incident ID: 32033049
Stack Signature	nsCaretAccessible::NotifySelectionChanged 400dc9ac
Product ID	Firefox2
Build ID	2007030919
Trigger Time	2007-05-11 04:27:14.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (0043ba02)
URL visited	live.com
User Comments	closing browser
Since Last Crash	44526 sec
Total Uptime	1014135 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/accessible/src/base/nsCaretAccessible.cpp, line 158
Stack Trace 	
nsCaretAccessible::NotifySelectionChanged  [mozilla/accessible/src/base/nsCaretAccessible.cpp, line 158]
nsTypedSelection::NotifySelectionListeners  [mozilla/layout/generic/nsSelection.cpp, line 8010]
nsSelection::NotifySelectionListeners  [mozilla/layout/generic/nsSelection.cpp, line 3117]
nsEventStateManager::MoveCaretToFocus  [mozilla/content/events/src/nsEventStateManager.cpp, line 5175]
nsGenericHTMLElement::SetElementFocus  [mozilla/content/html/content/src/nsGenericHTMLElement.cpp, line 3727]
nsGenericHTMLElement::Focus  [mozilla/content/html/content/src/nsGenericHTMLElement.cpp, line 3753]
XPCWrappedNative::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2169]
XPC_WN_CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1455]
js_Invoke  [mozilla/js/src/jsinterp.c, line 1396]
js_Interpret  [mozilla/js/src/jsinterp.c, line 3975]
js_Invoke  [mozilla/js/src/jsinterp.c, line 1415]
js_InternalInvoke  [mozilla/js/src/jsinterp.c, line 1490]
JS_CallFunctionValue  [mozilla/js/src/jsapi.c, line 4356]
nsJSContext::CallEventHandler  [mozilla/dom/src/base/nsJSEnvironment.cpp, line 1493]
nsJSEventListener::HandleEvent  [mozilla/dom/src/events/nsJSEventListener.cpp, line 195]
nsEventListenerManager::HandleEventSubType  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1655]
nsEventListenerManager::HandleEvent  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1762]
nsGlobalWindow::HandleDOMEvent  [mozilla/dom/src/base/nsGlobalWindow.cpp, line 1695]
DocumentViewerImpl::LoadComplete  [mozilla/layout/base/nsDocumentViewer.cpp, line 1016]
nsDocShell::EndPageLoad  [mozilla/docshell/base/nsDocShell.cpp, line 4795]
nsWebShell::EndPageLoad  [mozilla/docshell/base/nsWebShell.cpp, line 665]
nsDocShell::OnStateChange  [mozilla/docshell/base/nsDocShell.cpp, line 4710]
nsDocLoader::FireOnStateChange  [mozilla/uriloader/base/nsDocLoader.cpp, line 1210]
nsDocLoader::doStopDocumentLoad  [mozilla/uriloader/base/nsDocLoader.cpp, line 844]
nsDocLoader::DocLoaderIsEmpty  [mozilla/uriloader/base/nsDocLoader.cpp, line 744]
nsDocLoader::OnStopRequest  [mozilla/uriloader/base/nsDocLoader.cpp, line 665]
nsLoadGroup::RemoveRequest  [mozilla/netwerk/base/src/nsLoadGroup.cpp, line 732]
nsLoadGroup::Cancel  [mozilla/netwerk/base/src/nsLoadGroup.cpp, line 400]
nsDocLoader::Stop  [mozilla/uriloader/base/nsDocLoader.cpp, line 312]
nsDocLoader::Stop  [mozilla/uriloader/base/nsDocLoader.cpp, line 307]
nsDocLoader::Stop  [mozilla/uriloader/base/nsDocLoader.cpp, line 307]
nsDocShell::Stop  [mozilla/docshell/base/nsDocShell.cpp, line 3267]
nsDocShell::Destroy  [mozilla/docshell/base/nsDocShell.cpp, line 3510]
nsXULWindow::Destroy  [mozilla/xpfe/appshell/src/nsXULWindow.cpp, line 514]
nsWebShellWindow::Destroy  [mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 850]
nsWebShellWindow::HandleEvent  [mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 408]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1389]
nsWindow::DispatchStandardEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1429]
nsWindow::ProcessMessage  [mozilla/widget/src/windows/nsWindow.cpp, line 4584]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1577]
USER32.dll + 0x8734 (0x7e368734)
USER32.dll + 0x8816 (0x7e368816)
USER32.dll + 0xb4c0 (0x7e36b4c0)
USER32.dll + 0xb50c (0x7e36b50c)
ntdll.dll + 0xeae3 (0x7c91eae3)
USER32.dll + 0xb3f9 (0x7e36b3f9)
USER32.dll + 0xb393 (0x7e36b393)
nsWindow::DefaultWindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1603]
USER32.dll + 0x8734 (0x7e368734)
USER32.dll + 0x8816 (0x7e368816)
USER32.dll + 0xc63f (0x7e36c63f)
USER32.dll + 0xc665 (0x7e36c665)
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1584]
USER32.dll + 0x8734 (0x7e368734)
USER32.dll + 0x8816 (0x7e368816)
USER32.dll + 0xb4c0 (0x7e36b4c0)
USER32.dll + 0xb50c (0x7e36b50c)
ntdll.dll + 0xeae3 (0x7c91eae3)
USER32.dll + 0xb3f9 (0x7e36b3f9)
USER32.dll + 0xb393 (0x7e36b393)
nsWindow::DefaultWindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1603]
USER32.dll + 0x8734 (0x7e368734)
USER32.dll + 0x8816 (0x7e368816)
USER32.dll + 0xc63f (0x7e36c63f)
Summary: FF crashes sometimes when FF is closed → FF crashes sometimes when FF is closed [@ nsCaretAccessible::NotifySelectionChanged]
Version: unspecified → 2.0 Branch
Can you reproduce this crash with a new profile?
- http://kb.mozillazine.org/Profile_manager

Or in firefox's safemode?
- http://kb.mozillazine.org/Safe_mode
Severity: normal → critical
(Reporter)

Comment 3

12 years ago
The reproduction is not easy, due to the nature of the bug. It happens maybe once or twice every two weeks.
(Reporter)

Comment 4

11 years ago
the bug seems to be fixed in the current release 2.0.0.5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

8 years ago
Crash Signature: [@ nsCaretAccessible::NotifySelectionChanged]
You need to log in before you can comment on or make changes to this bug.