save form fields when restoring a crashed or saved session

RESOLVED DUPLICATE of bug 346337

Status

()

Firefox
Session Restore
--
minor
RESOLVED DUPLICATE of bug 346337
11 years ago
11 years ago

People

(Reporter: disgruntled.toaster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11

Firefox should save text fields when restoring a crashed or saved session.  If you're writing a long forum (or Bugzilla) post and the browser crashes, that is really frustrating since you lose the contents of it.  Maybe something like autosave should save form fields every few seconds in case the browser crashes?

Reproducible: Always

Steps to Reproduce:
1. write a long bugzilla bug
2. browser crashes, or you accidentally close firefox
3. start up that saved or crashed session
Actual Results:  
form fields aren't saved

Expected Results:  
save form fields

the only workaround is to write posts in an external editor

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 346337

Comment 2

11 years ago
This is only partially a duplicate of bug 346337. Much of it has indeed been implemented for Firefox 2.0 (there's a reason to update). Note however that due to privacy concerns, text fields aren't saved by default for web pages transmitted over a secure connection -- as is the case for Bugzilla.

See http://kb.mozillazine.org/browser.sessionstore.privacy_level for how to change that (or use an extension such as Tab Mix Plus or Session Manager to expose that preference for you).
(Reporter)

Comment 3

11 years ago
Thank you for the response and tips Simon; sorry about the dupe.

One annoying thing I'm coming up against now is from Vbulletin forums using javascript tricks to enable and disable form fields (eg., clicking edit, or how http://ubuntuforums.org disables the quick reply box unless you quote a post first, so you lose any text since the quick reply (or inline edit box) is again disabled on load).  I will have search for bug about that and file later.
You need to log in before you can comment on or make changes to this bug.