Closed Bug 380746 Opened 13 years ago Closed 13 years ago

webdav write failure if HTTP AUTH needed for PUT but not GET

Categories

(Calendar :: Provider: ICS/WebDAV, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 387559

People

(Reporter: mb/mozilla, Unassigned)

Details

(Whiteboard: [0.5 publish fails])

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.3) Gecko/20070417 Fedora/2.0.0.3-4.fc7 Firefox/2.0.0.3
Build Identifier: lightning 2007051503

Calendar is confused if it can successfully HTTP GET an ical file but PUT returns HTTP 401. It does ask the user for auth credentials, but doesn't try to issue an authenticated HTTP PUT (or perhaps it should do another GET first to be safe..)        


Reproducible: Always

Steps to Reproduce:
1. configure webdav server to require auth for PUT but not GET
2. put a cal file with an event on the server
3. tail -f access_log
4. fire up lightning, load the calendar
5. attempt to copy and paste the event
Actual Results:  
[load cal]

GET /cal.ics
  200 OK

[copy + paste]

GET /cal.ics
  200 OK
PUT /cal.ics  
  401 Auth required

[ask for user/pass]


Expected Results:  
[load cal]

GET /cal.ics
  200 OK

[copy + paste]

GET /cal.ics
  200 OK
PUT /cal.ics  
  401 Auth required

[ask for user/pass]

GET /cal.ics
  200 OK
PUT /cal.ics [with auth]
  204 OK

This sort of stuff in an Apache config will trigger the bug:

<LimitExcept GET OPTIONS>
   require valid-user
</LimitExcept>

You don't notice the bug if you Limit GET as well as PUT.
My Thunderbird is the i386 F7 build version "2.0.0.0 (20070419)".
sorry F7 = Fedora 7 (Linux)
I have exactly the same problem with sunbird 0.5, while sunbird 0.3.1 is ok. I have the .htaccess setup in my dav directory
<LimitExcept GET OPTIONS>
Order deny,allow
Allow from all
Require valid-user
</LimitExcept>

and PUT fives me "401 Auth requiresd". In sunbird 0.3.1 there is a pop-up to enter the user and password. In sunbird 0.5 it failes silently. 
Seems to be the same issue as in Bug 380291 (using LimitExcept rule) and is also noted in the release notes (last point on [http://www.mozilla.org/projects/calendar/releases/common0.5.html])
I have exactly the same problem. I would like to have read-only calendars for all users and write permissions set for a specific user.

This is no more possible with Lightning 0.5.
Whiteboard: [0.5 publish fails]
Matt, thank you for the clear bug report. During QA chat we decided to follow up this issue with Bug 387559 that has clear STR and information on the regression range.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 387559
Status: RESOLVED → VERIFIED
Bug 387559 is fixed now. I'd like you to retest with a Lightning 0.7pre (20070912) or newer build if your issue is entirely fixed now.
You need to log in before you can comment on or make changes to this bug.