Crash when removing <vbox> when mousedown + mouseover on <splitter>

RESOLVED FIXED

Status

()

Core
Event Handling
--
critical
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: smaug, Assigned: roc)

Tracking

({verified1.8.0.13, verified1.8.1.5})

1.8 Branch
x86
Linux
verified1.8.0.13, verified1.8.1.5
Points:
---
Bug Flags:
blocking1.8.1.5 +
wanted1.8.1.x +
blocking1.8.0.13 +
wanted1.8.0.x +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:critical?] trunk fixed by 311659)

Attachments

(1 attachment)

622 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

10 years ago
Created attachment 264985 [details]
testcase

This is apparently branch only.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311659
Given the trunk bug is public let's keep this one as the branch fix placeholder. Thanks for re-finding this, Olli.
Status: RESOLVED → REOPENED
Depends on: 311659
Flags: wanted1.8.1.x+
Flags: wanted1.8.0.x+
Flags: blocking1.8.1.5+
Flags: blocking1.8.0.13+
Resolution: DUPLICATE → ---
Whiteboard: [sg:critical?] trunk fixed by 311659
Roc: do we need a different patch for 311659 on the 1.8 branch, or does that one work?
Assignee: events → roc
Status: REOPENED → NEW
"fixed" for trunk to get this off the queries, but blocking the branch releases
Status: NEW → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
That patch should be good for branch

Updated

10 years ago
Keywords: fixed1.8.0.13, fixed1.8.1.5
verified fixed 1.8.1.5 using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5pre) Gecko/2007071003 BonEcho/2.0.0.5pre on Fedora F7 and the testcase in this bug. 

No crash on testcase - adding verified keyword
Keywords: fixed1.8.1.5 → verified1.8.1.5
This does not reproduce in Thunderbird 1.5.0.13 (2007080918) using Thunderbrowse. It also doesn't reproduce in Thunderbird 1.5.0.12 though.
verified fixed 1.8.0.13 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.0.13pre) Gecko/20070822 Firefox/1.5.0.13pre - no crash on testcase - adding verified keyword
Keywords: fixed1.8.0.13 → verified1.8.0.13
Group: security
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.