Find will not wrap or go to previous when viewing xml files

RESOLVED DUPLICATE of bug 263049

Status

()

--
major
RESOLVED DUPLICATE of bug 263049
12 years ago
10 years ago

People

(Reporter: scott, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20060601 Firefox/2.0.0.3 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20060601 Firefox/2.0.0.3 (Ubuntu-edgy)

When using find as you type or find when viewing an xml file, the previous search doesn't work, and the search won't wrap when it reaches the end of the document.

Reproducible: Always

Steps to Reproduce:
1. Go to an xml document (ie, http://www.w3schools.com/xml/cd_catalog.xml)
2. Press ctrl-f to find
3. Search for a string (ie, "artist")
4. Click next
5. Click previous (it does not go back)
6. Keeping clicking next until end of document
7. Click next one more time (it does not wrap search)
Actual Results:  
Search did not wrap, and the previous button did not work as designed.

Expected Results:  
Wrapped the search and the previous button should have worked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263049
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.