Last Comment Bug 381099 - Turn on crash reporting by default (Win+Mac)
: Turn on crash reporting by default (Win+Mac)
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 Mac OS X
: P1 normal (vote)
: Firefox 3 alpha5
Assigned To: Benjamin Smedberg [:bsmedberg]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-17 16:36 PDT by Benjamin Smedberg [:bsmedberg]
Modified: 2008-01-08 06:28 PST (History)
6 users (show)
benjamin: blocking‑firefox3+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
For when we're ready, rev. 1 (5.65 KB, patch)
2007-05-17 22:22 PDT, Benjamin Smedberg [:bsmedberg]
ted: review+
Details | Diff | Splinter Review

Description Benjamin Smedberg [:bsmedberg] 2007-05-17 16:36:25 PDT
As soon as the staging server is on, we should turn on breakpad for mac and windows. For mac, we're just going to switch cold-turkey. For Windows, we're going to build both talkback and breakpad. When both are enabled, talkback wins because it registers later, so we're going to make the talkback install percentage 50%
Comment 1 Benjamin Smedberg [:bsmedberg] 2007-05-17 22:22:25 PDT
Created attachment 265213 [details] [diff] [review]
For when we're ready, rev. 1
Comment 2 Ted Mielczarek [:ted.mielczarek] 2007-05-18 04:19:32 PDT
Comment on attachment 265213 [details] [diff] [review]
For when we're ready, rev. 1

Shouldn't we also turn this off on the mac tinderbox?
Comment 3 Benjamin Smedberg [:bsmedberg] 2007-05-18 06:01:17 PDT
Yes, but that's a separate patch because preed needs to review that.
Comment 4 Benjamin Smedberg [:bsmedberg] 2007-05-25 16:42:20 PDT
Fixed on trunk. Got r=rhelmer for disabling talkback on mac.
Comment 5 Carsten Book [:Tomcat] 2008-01-08 06:28:48 PST
verified fixed for linux, mac and windows xp

Note You need to log in before you can comment on or make changes to this bug.